summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-14 17:22:48 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-15 11:04:57 -0400
commit16e3eb02e9bcab8cd7e1529024e1ba1e70cf3a13 (patch)
tree7bb15a6c03414cf3a15e517cfdf7266ec378758a /dev-lang/php
parentnet-mail/list-remote-forwards: new package to find off-site mail forwards. (diff)
downloadgentoo-16e3eb02e9bcab8cd7e1529024e1ba1e70cf3a13.tar.gz
gentoo-16e3eb02e9bcab8cd7e1529024e1ba1e70cf3a13.tar.bz2
gentoo-16e3eb02e9bcab8cd7e1529024e1ba1e70cf3a13.zip
dev-lang/php: new revisions dropping depend.apache/apache-module.eclass.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-5.6.23-r3.ebuild (renamed from dev-lang/php/php-5.6.23-r2.ebuild)19
-rw-r--r--dev-lang/php/php-7.0.8-r2.ebuild (renamed from dev-lang/php/php-7.0.8-r1.ebuild)19
2 files changed, 18 insertions, 20 deletions
diff --git a/dev-lang/php/php-5.6.23-r2.ebuild b/dev-lang/php/php-5.6.23-r3.ebuild
index 071afe4e72df..6c1f34ed60a0 100644
--- a/dev-lang/php/php-5.6.23-r2.ebuild
+++ b/dev-lang/php/php-5.6.23-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils autotools flag-o-matic versionator depend.apache apache-module libtool systemd
+inherit eutils autotools flag-o-matic versionator libtool systemd
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
@@ -221,12 +221,6 @@ fi
PHP_INI_FILE="php.ini"
-want_apache
-
-pkg_setup() {
- depend.apache_pkg_setup
-}
-
php_install_ini() {
local phpsapi="${1}"
@@ -744,9 +738,14 @@ src_test() {
pkg_postinst() {
# Output some general info to the user
if use apache2 ; then
- APACHE2_MOD_DEFINE="PHP"
- APACHE2_MOD_CONF="70_mod_php" # Provided by app-eselect/eselect-php
- apache-module_pkg_postinst
+ elog
+ elog "To enable PHP in apache, you will need to add \"-D PHP\" to"
+ elog "your apache2 command. OpenRC users can append that string to"
+ elog "APACHE2_OPTS in /etc/conf.d/apache2."
+ elog
+ elog "The apache module configuration file 70_mod_php.conf is"
+ elog "provided (and maintained) by eselect-php."
+ elog
fi
# Create the symlinks for php
diff --git a/dev-lang/php/php-7.0.8-r1.ebuild b/dev-lang/php/php-7.0.8-r2.ebuild
index 9bd15572e425..4ed4d7492bfa 100644
--- a/dev-lang/php/php-7.0.8-r1.ebuild
+++ b/dev-lang/php/php-7.0.8-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils autotools flag-o-matic versionator depend.apache apache-module libtool systemd
+inherit eutils autotools flag-o-matic versionator libtool systemd
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
@@ -212,12 +212,6 @@ fi
PHP_INI_FILE="php.ini"
-want_apache
-
-pkg_setup() {
- depend.apache_pkg_setup
-}
-
php_install_ini() {
local phpsapi="${1}"
@@ -738,9 +732,14 @@ src_test() {
pkg_postinst() {
# Output some general info to the user
if use apache2 ; then
- APACHE2_MOD_DEFINE="PHP"
- APACHE2_MOD_CONF="70_mod_php" # Provided by app-eselect/eselect-php
- apache-module_pkg_postinst
+ elog
+ elog "To enable PHP in apache, you will need to add \"-D PHP\" to"
+ elog "your apache2 command. OpenRC users can append that string to"
+ elog "APACHE2_OPTS in /etc/conf.d/apache2."
+ elog
+ elog "The apache module configuration file 70_mod_php.conf is"
+ elog "provided (and maintained) by eselect-php."
+ elog
fi
# Create the symlinks for php