summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-27 20:43:01 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-28 09:45:39 -0500
commitb3035c9a156c3d57cb14f1d712fa8576d6877e7d (patch)
treee036e266b9c2399e099a4be72e555035a619638f /dev-lang/php
parentdev-lang/php: remove "minor" from "minor version slotting" in elogs. (diff)
downloadgentoo-b3035c9a156c3d57cb14f1d712fa8576d6877e7d.tar.gz
gentoo-b3035c9a156c3d57cb14f1d712fa8576d6877e7d.tar.bz2
gentoo-b3035c9a156c3d57cb14f1d712fa8576d6877e7d.zip
dev-lang/php: enforce what was an elog warning with REQUIRED_USE.
The interactive "php -a" command-line interface will hang unless PHP is built with USE=readline. This used to be an elog warning, but was rather easy to overlook and mysterious to those who hit the bug. We already have REQUIRED_USE for our other flags, so it makes sense to enforce the cli dependency on readline there. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-5.6.17-r5.ebuild (renamed from dev-lang/php/php-5.6.17-r4.ebuild)7
-rw-r--r--dev-lang/php/php-7.0.2-r5.ebuild (renamed from dev-lang/php/php-7.0.2-r4.ebuild)7
2 files changed, 4 insertions, 10 deletions
diff --git a/dev-lang/php/php-5.6.17-r4.ebuild b/dev-lang/php/php-5.6.17-r5.ebuild
index 184650ea954c..82e7a03ede15 100644
--- a/dev-lang/php/php-5.6.17-r4.ebuild
+++ b/dev-lang/php/php-5.6.17-r5.ebuild
@@ -165,7 +165,9 @@ DEPEND="${DEPEND}
php="=${CATEGORY}/${PF}"
+# Without USE=readline, the interactive "php -a" CLI will hang.
REQUIRED_USE="
+ cli? ( readline )
truetype? ( gd )
vpx? ( gd )
cjk? ( gd )
@@ -774,11 +776,6 @@ pkg_postinst() {
elog "Make sure that PHP_TARGETS in ${EPREFIX}/etc/make.conf includes"
elog "php${SLOT/./-} in order to compile extensions for the ${SLOT} ABI."
elog
- if ! use readline && use cli ; then
- ewarn "Note that in order to use php interactivly, you need to"
- ewarn "enable the readline USE flag or php -a will hang."
- elog
- fi
elog "This ebuild installed a version of php.ini based on"
elog "php.ini-${PHP_INI_VERSION}. You can choose which version of"
elog "php.ini to install by default by setting PHP_INI_VERSION"
diff --git a/dev-lang/php/php-7.0.2-r4.ebuild b/dev-lang/php/php-7.0.2-r5.ebuild
index f5d481896a98..e502be41dadb 100644
--- a/dev-lang/php/php-7.0.2-r4.ebuild
+++ b/dev-lang/php/php-7.0.2-r5.ebuild
@@ -158,7 +158,9 @@ DEPEND="${DEPEND}
php="=${CATEGORY}/${PF}"
+# Without USE=readline, the interactive "php -a" CLI will hang.
REQUIRED_USE="
+ cli? ( readline )
truetype? ( gd )
vpx? ( gd )
cjk? ( gd )
@@ -766,11 +768,6 @@ pkg_postinst() {
elog "Make sure that PHP_TARGETS in ${EPREFIX}/etc/make.conf includes"
elog "php${SLOT/./-} in order to compile extensions for the ${SLOT} ABI."
elog
- if ! use readline && use cli ; then
- ewarn "Note that in order to use php interactivly, you need to"
- ewarn "enable the readline USE flag or php -a will hang."
- elog
- fi
elog "This ebuild installed a version of php.ini based on"
elog "php.ini-${PHP_INI_VERSION}. You can choose which version of"
elog "php.ini to install by default by setting PHP_INI_VERSION"