summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-09-17 13:40:33 -0400
committerBrian Evans <grknight@gentoo.org>2019-09-17 13:40:33 -0400
commitd021621e343e8f247c92e48c00dc3f604299928d (patch)
treeb03b93ea63d8368d4524d8a846618b7cee693f10 /dev-lang/php
parentdev-libs/libpwquality: bump to 1.4.1; add py3.7, remove 2.7 (diff)
downloadgentoo-d021621e343e8f247c92e48c00dc3f604299928d.tar.gz
gentoo-d021621e343e8f247c92e48c00dc3f604299928d.tar.bz2
gentoo-d021621e343e8f247c92e48c00dc3f604299928d.zip
dev-lang/php: Emulate PHP ./buildconf in PHP 7.4
Upstream has changed how macros are defined by the autoconf system This breaks eautoreconf with latest libtool. Previously we attempted to copy in new libtool, but this breaks external extensions. Instead, do what upstream expects using our own tools to ensure cross-compliation support. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-7.4.0_rc1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/php/php-7.4.0_rc1.ebuild b/dev-lang/php/php-7.4.0_rc1.ebuild
index 4c04d93e4d4d..fafdcb64e838 100644
--- a/dev-lang/php/php-7.4.0_rc1.ebuild
+++ b/dev-lang/php/php-7.4.0_rc1.ebuild
@@ -218,9 +218,11 @@ src_prepare() {
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
- # Bug 669566 - necessary so that build tools are updated for commands like pecl
- cp "${BROOT}/usr/share/aclocal/libtool.m4" build/ || die
- eautoreconf
+ # Emulate buildconf to support cross-compilation
+ rm -fr aclocal.m4 autom4te.cache config.cache \
+ configure main/php_config.h.in || die
+ eautoconf --force
+ eautoheader
}
src_configure() {