summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-03-03 15:03:41 -0500
committerBrian Evans <grknight@gentoo.org>2020-03-03 15:03:41 -0500
commitfed428ca9f0daa92a61d8d6a8875cb4a1e84cbf0 (patch)
treea13260b7607ecddf9fdda2009475f1427be3893f /dev-lang/php
parentmedia-video/vdr: old buggy version removed (diff)
downloadgentoo-fed428ca9f0daa92a61d8d6a8875cb4a1e84cbf0.tar.gz
gentoo-fed428ca9f0daa92a61d8d6a8875cb4a1e84cbf0.tar.bz2
gentoo-fed428ca9f0daa92a61d8d6a8875cb4a1e84cbf0.zip
dev-lang/php: Use relative symlinks; whitespace
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-7.2.28-r1.ebuild12
-rw-r--r--dev-lang/php/php-7.3.15-r1.ebuild12
-rw-r--r--dev-lang/php/php-7.4.3-r1.ebuild4
3 files changed, 14 insertions, 14 deletions
diff --git a/dev-lang/php/php-7.2.28-r1.ebuild b/dev-lang/php/php-7.2.28-r1.ebuild
index 96047b4e6677..e032d1b3af00 100644
--- a/dev-lang/php/php-7.2.28-r1.ebuild
+++ b/dev-lang/php/php-7.2.28-r1.ebuild
@@ -557,11 +557,11 @@ src_install() {
case "$sapi" in
cli)
source="sapi/cli/php"
- # Install the "phar" archive utility.
- if use phar ; then
- emake INSTALL_ROOT="${D}" install-pharcmd
- dosym "${dest}/bin/phar" "/usr/bin/phar${SLOT}"
- fi
+ # Install the "phar" archive utility.
+ if use phar ; then
+ emake INSTALL_ROOT="${D}" install-pharcmd
+ dosym "..${dest#/usr}/bin/phar" "/usr/bin/phar${SLOT}"
+ fi
;;
cgi)
source="sapi/cgi/php-cgi"
@@ -585,7 +585,7 @@ src_install() {
else
dobin "${source}"
local name="$(basename ${source})"
- dosym "${dest}/bin/${name}" "/usr/bin/${name}${SLOT}"
+ dosym "..${dest#/usr}/bin/${name}" "/usr/bin/${name}${SLOT}"
fi
fi
diff --git a/dev-lang/php/php-7.3.15-r1.ebuild b/dev-lang/php/php-7.3.15-r1.ebuild
index 1726c6222789..75ec441d1c32 100644
--- a/dev-lang/php/php-7.3.15-r1.ebuild
+++ b/dev-lang/php/php-7.3.15-r1.ebuild
@@ -558,11 +558,11 @@ src_install() {
case "$sapi" in
cli)
source="sapi/cli/php"
- # Install the "phar" archive utility.
- if use phar ; then
- emake INSTALL_ROOT="${D}" install-pharcmd
- dosym "${dest}/bin/phar" "/usr/bin/phar${SLOT}"
- fi
+ # Install the "phar" archive utility.
+ if use phar ; then
+ emake INSTALL_ROOT="${D}" install-pharcmd
+ dosym "..${dest#/usr}/bin/phar" "/usr/bin/phar${SLOT}"
+ fi
;;
cgi)
source="sapi/cgi/php-cgi"
@@ -586,7 +586,7 @@ src_install() {
else
dobin "${source}"
local name="$(basename ${source})"
- dosym "${dest}/bin/${name}" "/usr/bin/${name}${SLOT}"
+ dosym "..${dest#/usr}/bin/${name}" "/usr/bin/${name}${SLOT}"
fi
fi
diff --git a/dev-lang/php/php-7.4.3-r1.ebuild b/dev-lang/php/php-7.4.3-r1.ebuild
index 3701941e2440..f2c76031d7de 100644
--- a/dev-lang/php/php-7.4.3-r1.ebuild
+++ b/dev-lang/php/php-7.4.3-r1.ebuild
@@ -551,7 +551,7 @@ src_install() {
# Install the "phar" archive utility.
if use phar ; then
emake INSTALL_ROOT="${D}" install-pharcmd
- dosym "${dest}/bin/phar" "/usr/bin/phar${SLOT}"
+ dosym "..${dest#/usr}/bin/phar" "/usr/bin/phar${SLOT}"
fi
;;
cgi)
@@ -576,7 +576,7 @@ src_install() {
else
dobin "${source}"
local name="$(basename ${source})"
- dosym "${dest}/bin/${name}" "/usr/bin/${name}${SLOT}"
+ dosym "..${dest#/usr}/bin/${name}" "/usr/bin/${name}${SLOT}"
fi
fi