summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-10 18:54:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-10 18:54:05 +0200
commit6db034e29ca9ebb18c77c6f4e2e2b741d5a52480 (patch)
treeb65193d4d05ce82f36a736df23d264f87ef97a99 /dev-lang/python-exec
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.125 (diff)
downloadgentoo-6db034e29ca9ebb18c77c6f4e2e2b741d5a52480.tar.gz
gentoo-6db034e29ca9ebb18c77c6f4e2e2b741d5a52480.tar.bz2
gentoo-6db034e29ca9ebb18c77c6f4e2e2b741d5a52480.zip
dev-lang/python-exec: Bump to 2.4.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/Manifest1
-rw-r--r--dev-lang/python-exec/python-exec-2.4.8.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index 6e24c7ca4a59..1bacf6a3b560 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1,2 +1,3 @@
DIST python-exec-2.4.6.tar.bz2 87634 BLAKE2B 7b6de8ad0e0603fafd3284e6e3c5247ad83f145ab4db6728914318ae8e6f5aaa3c0247f4e01238fca11519ef72fb1b11436aea7e2b8c988b8717b3f6a2a43c37 SHA512 e05eaf01b83de196a10933636ab6b1a5489a421592df49b8b58eabd0e732de970f902744cd3a06b5ab530a6d69fe6dfa8f270fbb09b9fe3df4ae04d516828050
DIST python-exec-2.4.7.tar.bz2 88204 BLAKE2B c370d5f33063bf0dd02d1b5ddad27b320652664ed3bc89cf2d70b94292f3dcd8c4e3bb6bb43ce8d2514a8e0a5a3e95295ff8d0f95371bda136cd51312da747e8 SHA512 6e061fc1ae84e21effb24d35195a7c61430e0e50dc0b0bfbab65f741dde45a92688fd9ac7a0868f7b08ba603a609fb3f03181238f63fdd383b4d604af8406d14
+DIST python-exec-2.4.8.tar.bz2 82671 BLAKE2B ac85f3dd6da3d1c535ad56a25edbbcb1d0e75b91e3567b80f27fd01d32a199a713909a8552dffaacbe96c43bca491f31c3f0c7f1a618fb9144814365686715cf SHA512 d6dabab217dc2f1817e2f4d159102a9467f51b26b91f4ae7fb7e4930d30334f74bd8a5f37cc60d58c6e1e61e89a3b4d2e1bd17413493ba86f38fa71250cf5ac1
diff --git a/dev-lang/python-exec/python-exec-2.4.8.ebuild b/dev-lang/python-exec/python-exec-2.4.8.ebuild
new file mode 100644
index 000000000000..ba9bc52a3a43
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-2.4.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit python-any-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://github.com/mgorny/python-exec/"
+SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# Internal Python project hack. Do not copy it. Ever.
+IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_} +native-symlinks test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/python-exec-conf
+ !<=dev-lang/python-2.7.18-r3:2.7"
+BDEPEND="
+ test? (
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
+
+python_check_deps() {
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local pyimpls=() i EPYTHON
+ for i in "${_PYTHON_ALL_IMPLS[@]}"; do
+ if use "python_targets_${i}"; then
+ _python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
+ fi
+ done
+
+ local myconf=(
+ --with-fallback-path="${EPREFIX}/usr/local/sbin:${EPREFIX}/usr/local/bin:${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
+ --with-python-impls="${pyimpls[*]}"
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if use native-symlinks; then
+ local programs=( python python3 )
+ local scripts=( python-config python3-config 2to3 idle pydoc pyvenv )
+
+ local f
+ for f in "${programs[@]}"; do
+ # symlink the C wrapper for python to avoid shebang recursion
+ # bug #568974
+ dosym python-exec2c /usr/bin/"${f}"
+ done
+ for f in "${scripts[@]}"; do
+ # those are python scripts (except for new python-configs)
+ # so symlink them via the python wrapper
+ dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ done
+ fi
+}