summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-11-11 19:18:49 -0500
committerMike Gilbert <floppym@gentoo.org>2015-11-11 19:45:27 -0500
commit1e379f1f1a61be360bf9cf59030e15862c2a3d21 (patch)
treeafcb2ce9d2e5ade6a07c0b0a66231fffa4ecb3c3 /dev-lang/python/python-2.7.10-r3.ebuild
parentrev bump to push out the patch (bug #563906) (diff)
downloadgentoo-1e379f1f1a61be360bf9cf59030e15862c2a3d21.tar.gz
gentoo-1e379f1f1a61be360bf9cf59030e15862c2a3d21.tar.bz2
gentoo-1e379f1f1a61be360bf9cf59030e15862c2a3d21.zip
dev-lang/python: Set PYTHON_SITEDIR manually
The eclass change in fd4001e9 causes python_export to call ${PYTHON} to obtain PYTHON_SITEDIR. This returns an empty string if ${PYTHON} has not yet been merged. Package-Manager: portage-2.2.23_p26
Diffstat (limited to 'dev-lang/python/python-2.7.10-r3.ebuild')
-rw-r--r--dev-lang/python/python-2.7.10-r3.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/python/python-2.7.10-r3.ebuild b/dev-lang/python/python-2.7.10-r3.ebuild
index 70d8d82916b8..31c6506f0e69 100644
--- a/dev-lang/python/python-2.7.10-r3.ebuild
+++ b/dev-lang/python/python-2.7.10-r3.ebuild
@@ -304,7 +304,8 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ python_export python${SLOT} EPYTHON PYTHON
+ export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then