summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-18 09:54:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-18 10:03:54 +0200
commita2cb4f6a8da80865a65bbebd5cf749e4cab8ae62 (patch)
treed9e2dfec1a8545087fddb55d357abc594b29a37d /dev-lang/python/python-3.8.5.ebuild
parentdev-lang/python: Remove 3.9.0 betas (diff)
downloadgentoo-a2cb4f6a8da80865a65bbebd5cf749e4cab8ae62.tar.gz
gentoo-a2cb4f6a8da80865a65bbebd5cf749e4cab8ae62.tar.bz2
gentoo-a2cb4f6a8da80865a65bbebd5cf749e4cab8ae62.zip
dev-lang/python: Respect MAKEOPTS throughout the build
Closes: https://bugs.gentoo.org/737660 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python/python-3.8.5.ebuild')
-rw-r--r--dev-lang/python/python-3.8.5.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.8.5.ebuild b/dev-lang/python/python-3.8.5.ebuild
index c2a10d038554..df05aaedef1f 100644
--- a/dev-lang/python/python-3.8.5.ebuild
+++ b/dev-lang/python/python-3.8.5.ebuild
@@ -4,7 +4,8 @@
EAPI="7"
WANT_LIBTOOL="none"
-inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
+inherit autotools flag-o-matic multiprocessing pax-utils \
+ python-utils-r1 toolchain-funcs
MY_P="Python-${PV}"
PYVER=$(ver_cut 1-2)
@@ -73,6 +74,12 @@ src_prepare() {
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+ # force correct number of jobs
+ # https://bugs.gentoo.org/737660
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+ sed -i -e "s:-j0:-j${jobs}:" Makefile.pre.in || die
+ sed -i -e "/self\.parallel/s:True:${jobs}:" setup.py || die
+
eautoreconf
}
@@ -185,10 +192,12 @@ src_test() {
# bug 660358
local -x COLUMNS=80
-
local -x PYTHONDONTWRITEBYTECODE=
- emake test EXTRATESTOPTS="-u-network" CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+
+ emake test EXTRATESTOPTS="-u-network -j${jobs}" \
+ CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local result=$?
for test in ${skipped_tests}; do