summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-17 16:33:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-17 22:08:07 +0100
commit38d84cce8a1f286a43421f5ff7a2067ad95fcaa3 (patch)
tree39b2086a4ceab1d141d841294bc9a76790c4d5fe /dev-lang/python
parentnet-p2p/syncthing: disable tests again in 0.12.19, fix hasn't landed yet (diff)
downloadgentoo-38d84cce8a1f286a43421f5ff7a2067ad95fcaa3.tar.gz
gentoo-38d84cce8a1f286a43421f5ff7a2067ad95fcaa3.tar.bz2
gentoo-38d84cce8a1f286a43421f5ff7a2067ad95fcaa3.zip
dev-lang/python:{2.7,3.4,3.5}: Move epatch_user call before sedding libdir. Bug #574962.
This allows sharing patches between different architectures where libdir differ. Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.11-r2.ebuild4
-rw-r--r--dev-lang/python/python-3.4.3-r7.ebuild4
-rw-r--r--dev-lang/python/python-3.5.1-r2.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/python/python-2.7.11-r2.ebuild b/dev-lang/python/python-2.7.11-r2.ebuild
index 6fccccee1e80..d9fd3d660f72 100644
--- a/dev-lang/python/python-2.7.11-r2.ebuild
+++ b/dev-lang/python/python-2.7.11-r2.ebuild
@@ -104,6 +104,8 @@ src_prepare() {
epatch "${FILESDIR}/python-2.7.10-cross-compile-warn-test.patch"
epatch "${FILESDIR}/python-2.7.10-system-libffi.patch"
+ epatch_user
+
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
Lib/distutils/sysconfig.py \
@@ -115,8 +117,6 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- epatch_user
-
eautoreconf
}
diff --git a/dev-lang/python/python-3.4.3-r7.ebuild b/dev-lang/python/python-3.4.3-r7.ebuild
index f599fd900e5a..8272a412760d 100644
--- a/dev-lang/python/python-3.4.3-r7.ebuild
+++ b/dev-lang/python/python-3.4.3-r7.ebuild
@@ -75,6 +75,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
epatch "${FILESDIR}/${PN}-3.4-gcc-5.patch" #547626
+ epatch_user
+
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
Lib/distutils/sysconfig.py \
@@ -86,8 +88,6 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- epatch_user
-
eautoreconf
}
diff --git a/dev-lang/python/python-3.5.1-r2.ebuild b/dev-lang/python/python-3.5.1-r2.ebuild
index 7f82e77d001c..d73faa1d5e60 100644
--- a/dev-lang/python/python-3.5.1-r2.ebuild
+++ b/dev-lang/python/python-3.5.1-r2.ebuild
@@ -73,6 +73,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
epatch "${FILESDIR}/3.5-secondary-targets.patch"
+ epatch_user
+
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
configure.ac \
Lib/distutils/command/install.py \
@@ -87,8 +89,6 @@ src_prepare() {
#sed -i -e 's/\$(GRAMMAR_H): \$(GRAMMAR_INPUT) \$(PGEN)/$(GRAMMAR_H): \$(GRAMMAR_INPUT)/' Makefile.pre.in || die
- epatch_user
-
eautoreconf
}