summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-10-31 13:31:45 -0400
committerMike Gilbert <floppym@gentoo.org>2017-10-31 13:35:06 -0400
commite47a2221253a05b34be839a49cdd670632c6cfd5 (patch)
tree6e17c1b9f5ece6b31227c9a3b3d829ecc8554c4a /dev-lang/python
parentdev-libs/cgicc: amd64 stable, bug 632362 (diff)
downloadgentoo-e47a2221253a05b34be839a49cdd670632c6cfd5.tar.gz
gentoo-e47a2221253a05b34be839a49cdd670632c6cfd5.tar.bz2
gentoo-e47a2221253a05b34be839a49cdd670632c6cfd5.zip
dev-lang/python: use absolute path in LD_LIBRARY_PATH
Closes: https://bugs.gentoo.org/608312 Package-Manager: Portage-2.3.12_p5, Repoman-2.3.3_p75
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.14.ebuild2
-rw-r--r--dev-lang/python/python-3.4.5.ebuild2
-rw-r--r--dev-lang/python/python-3.4.6.ebuild2
-rw-r--r--dev-lang/python/python-3.6.3.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.7.14.ebuild b/dev-lang/python/python-2.7.14.ebuild
index 5e5cbbf19174..ea9388be52df 100644
--- a/dev-lang/python/python-2.7.14.ebuild
+++ b/dev-lang/python/python-2.7.14.ebuild
@@ -312,7 +312,7 @@ src_install() {
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
local -x PYTHON=./python
- local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
else
vars=( PYTHON "${vars[@]}" )
fi
diff --git a/dev-lang/python/python-3.4.5.ebuild b/dev-lang/python/python-3.4.5.ebuild
index 5586215492b1..20fadf8ea6fb 100644
--- a/dev-lang/python/python-3.4.5.ebuild
+++ b/dev-lang/python/python-3.4.5.ebuild
@@ -284,7 +284,7 @@ src_install() {
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
local -x PYTHON=./python
- local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
else
vars=( PYTHON "${vars[@]}" )
fi
diff --git a/dev-lang/python/python-3.4.6.ebuild b/dev-lang/python/python-3.4.6.ebuild
index f5d3c43753b3..80dffce2af54 100644
--- a/dev-lang/python/python-3.4.6.ebuild
+++ b/dev-lang/python/python-3.4.6.ebuild
@@ -284,7 +284,7 @@ src_install() {
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
local -x PYTHON=./python
- local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
else
vars=( PYTHON "${vars[@]}" )
fi
diff --git a/dev-lang/python/python-3.6.3.ebuild b/dev-lang/python/python-3.6.3.ebuild
index fa67a439bfa2..4cf258819ee0 100644
--- a/dev-lang/python/python-3.6.3.ebuild
+++ b/dev-lang/python/python-3.6.3.ebuild
@@ -270,7 +270,7 @@ src_install() {
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
local -x PYTHON=./python
- local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}${PWD}
else
vars=( PYTHON "${vars[@]}" )
fi