summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-25 00:07:56 +0100
committerSam James <sam@gentoo.org>2021-06-25 00:27:36 +0100
commit08512e9e4f2ef9e713aa42925aa7dbbc19ad8786 (patch)
treeb966fb7dff0dae54120bbafa73efdc929c7c477e /dev-lang/ruby
parentapp-i18n/freewnn: add virtual/libcrypt dependency (diff)
downloadgentoo-08512e9e4f2ef9e713aa42925aa7dbbc19ad8786.tar.gz
gentoo-08512e9e4f2ef9e713aa42925aa7dbbc19ad8786.tar.bz2
gentoo-08512e9e4f2ef9e713aa42925aa7dbbc19ad8786.zip
dev-lang/ruby: add missing dependency on virtual/libcrypt
Let's do all the versions just to be sure given some people are on older ones for now. Needed for libxcrypt migration which is upcoming. (We also add a subslot operator for jemalloc. It's not expected to break ABI at the moment, but adding it while here. Not going to bother to revbumping for it given this is just being done for the benefit of future copies.) Fixes: ab5f27d955cc4bd9124b159e494266ffae6e230e Reported-by: Ionen Wolkens <ionen@gentoo.org> Reported-by: Andreas K. Hüttel <dilfridge@gentoo.org> Acked-by: David Seifert <soap@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ruby-2.5.8-r2.ebuild (renamed from dev-lang/ruby/ruby-2.5.8.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.5.8-r3.ebuild (renamed from dev-lang/ruby/ruby-2.5.8-r1.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.5.9-r1.ebuild2
-rw-r--r--dev-lang/ruby/ruby-2.6.6-r4.ebuild (renamed from dev-lang/ruby/ruby-2.6.6-r2.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.6.6-r5.ebuild (renamed from dev-lang/ruby/ruby-2.6.6-r3.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.6.7-r1.ebuild2
-rw-r--r--dev-lang/ruby/ruby-2.7.2-r2.ebuild (renamed from dev-lang/ruby/ruby-2.7.2.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.7.2-r3.ebuild (renamed from dev-lang/ruby/ruby-2.7.2-r1.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.7.3-r3.ebuild (renamed from dev-lang/ruby/ruby-2.7.3.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-2.7.3-r4.ebuild (renamed from dev-lang/ruby/ruby-2.7.3-r2.ebuild)2
-rw-r--r--dev-lang/ruby/ruby-3.0.0-r3.ebuild (renamed from dev-lang/ruby/ruby-3.0.0.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-3.0.0-r4.ebuild (renamed from dev-lang/ruby/ruby-3.0.0-r1.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-3.0.0-r5.ebuild (renamed from dev-lang/ruby/ruby-3.0.0-r2.ebuild)3
-rw-r--r--dev-lang/ruby/ruby-3.0.1-r1.ebuild2
14 files changed, 24 insertions, 14 deletions
diff --git a/dev-lang/ruby/ruby-2.5.8.ebuild b/dev-lang/ruby/ruby-2.5.8-r2.ebuild
index 26ccd6669a8c..b8c9bb040a1e 100644
--- a/dev-lang/ruby/ruby-2.5.8.ebuild
+++ b/dev-lang/ruby/ruby-2.5.8-r2.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc +rdoc rubytests socks5 +ssl s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
ssl? (
dev-libs/openssl:0=
)
@@ -36,6 +36,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20171225
"
diff --git a/dev-lang/ruby/ruby-2.5.8-r1.ebuild b/dev-lang/ruby/ruby-2.5.8-r3.ebuild
index 67217e9b50d5..750b9e0ddb39 100644
--- a/dev-lang/ruby/ruby-2.5.8-r1.ebuild
+++ b/dev-lang/ruby/ruby-2.5.8-r3.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc +rdoc rubytests socks5 +ssl s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
ssl? (
dev-libs/openssl:0=
)
@@ -37,6 +37,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20171225
"
diff --git a/dev-lang/ruby/ruby-2.5.9-r1.ebuild b/dev-lang/ruby/ruby-2.5.9-r1.ebuild
index ad8c1d6bebba..750b9e0ddb39 100644
--- a/dev-lang/ruby/ruby-2.5.9-r1.ebuild
+++ b/dev-lang/ruby/ruby-2.5.9-r1.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc +rdoc rubytests socks5 +ssl s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
ssl? (
dev-libs/openssl:0=
)
diff --git a/dev-lang/ruby/ruby-2.6.6-r2.ebuild b/dev-lang/ruby/ruby-2.6.6-r4.ebuild
index 427fdb2a5226..96442510f258 100644
--- a/dev-lang/ruby/ruby-2.6.6-r2.ebuild
+++ b/dev-lang/ruby/ruby-2.6.6-r4.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20181225
"
diff --git a/dev-lang/ruby/ruby-2.6.6-r3.ebuild b/dev-lang/ruby/ruby-2.6.6-r5.ebuild
index e14b3d9f9419..14fd240b2ddc 100644
--- a/dev-lang/ruby/ruby-2.6.6-r3.ebuild
+++ b/dev-lang/ruby/ruby-2.6.6-r5.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20181225
"
diff --git a/dev-lang/ruby/ruby-2.6.7-r1.ebuild b/dev-lang/ruby/ruby-2.6.7-r1.ebuild
index 056be37e79c0..14fd240b2ddc 100644
--- a/dev-lang/ruby/ruby-2.6.7-r1.ebuild
+++ b/dev-lang/ruby/ruby-2.6.7-r1.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
diff --git a/dev-lang/ruby/ruby-2.7.2.ebuild b/dev-lang/ruby/ruby-2.7.2-r2.ebuild
index 3037150562ee..f798dc8d5157 100644
--- a/dev-lang/ruby/ruby-2.7.2.ebuild
+++ b/dev-lang/ruby/ruby-2.7.2-r2.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20191222
"
diff --git a/dev-lang/ruby/ruby-2.7.2-r1.ebuild b/dev-lang/ruby/ruby-2.7.2-r3.ebuild
index 8630ad06ae8c..d0bd2d0867a1 100644
--- a/dev-lang/ruby/ruby-2.7.2-r1.ebuild
+++ b/dev-lang/ruby/ruby-2.7.2-r3.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20191222
"
diff --git a/dev-lang/ruby/ruby-2.7.3.ebuild b/dev-lang/ruby/ruby-2.7.3-r3.ebuild
index 8630ad06ae8c..d0bd2d0867a1 100644
--- a/dev-lang/ruby/ruby-2.7.3.ebuild
+++ b/dev-lang/ruby/ruby-2.7.3-r3.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20191222
"
diff --git a/dev-lang/ruby/ruby-2.7.3-r2.ebuild b/dev-lang/ruby/ruby-2.7.3-r4.ebuild
index ae0de75300f2..9303360e071b 100644
--- a/dev-lang/ruby/ruby-2.7.3-r2.ebuild
+++ b/dev-lang/ruby/ruby-2.7.3-r4.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
diff --git a/dev-lang/ruby/ruby-3.0.0.ebuild b/dev-lang/ruby/ruby-3.0.0-r3.ebuild
index 6af89cd13458..993097d71ceb 100644
--- a/dev-lang/ruby/ruby-3.0.0.ebuild
+++ b/dev-lang/ruby/ruby-3.0.0-r3.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20201225
"
diff --git a/dev-lang/ruby/ruby-3.0.0-r1.ebuild b/dev-lang/ruby/ruby-3.0.0-r4.ebuild
index 948a1294676b..c42410d89840 100644
--- a/dev-lang/ruby/ruby-3.0.0-r1.ebuild
+++ b/dev-lang/ruby/ruby-3.0.0-r4.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20201225
"
diff --git a/dev-lang/ruby/ruby-3.0.0-r2.ebuild b/dev-lang/ruby/ruby-3.0.0-r5.ebuild
index 37743ff87091..219a641a6d3f 100644
--- a/dev-lang/ruby/ruby-3.0.0-r2.ebuild
+++ b/dev-lang/ruby/ruby-3.0.0-r5.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=
@@ -38,6 +38,7 @@ RDEPEND="
dev-libs/libffi:=
sys-libs/readline:0=
sys-libs/zlib
+ virtual/libcrypt:=
>=app-eselect/eselect-ruby-20201225
"
diff --git a/dev-lang/ruby/ruby-3.0.1-r1.ebuild b/dev-lang/ruby/ruby-3.0.1-r1.ebuild
index 26f16571a638..f4461ac9e944 100644
--- a/dev-lang/ruby/ruby-3.0.1-r1.ebuild
+++ b/dev-lang/ruby/ruby-3.0.1-r1.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +s
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm:= )
- jemalloc? ( dev-libs/jemalloc )
+ jemalloc? ( dev-libs/jemalloc:= )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
dev-libs/openssl:0=