summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-20 20:38:34 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-20 20:40:28 +0200
commit358fb4c3f5094919d6f4c7222a591dfc79219032 (patch)
treef43ae16a372a220401614f41dcb4a38d18441767 /dev-lang/ruby
parentdev-util/artifactory-bin: version bump (diff)
downloadgentoo-358fb4c3f5094919d6f4c7222a591dfc79219032.tar.gz
gentoo-358fb4c3f5094919d6f4c7222a591dfc79219032.tar.bz2
gentoo-358fb4c3f5094919d6f4c7222a591dfc79219032.zip
dev-lang/ruby: add back tk support
Initial patches by Arfrever Frehtes Taifersar Arahesis in bug 497130 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ruby-2.1.10.ebuild18
-rw-r--r--dev-lang/ruby/ruby-2.2.5.ebuild18
-rw-r--r--dev-lang/ruby/ruby-2.3.1.ebuild16
3 files changed, 29 insertions, 23 deletions
diff --git a/dev-lang/ruby/ruby-2.1.10.ebuild b/dev-lang/ruby/ruby-2.1.10.ebuild
index f49f79df6f2..abc19325776 100644
--- a/dev-lang/ruby/ruby-2.1.10.ebuild
+++ b/dev-lang/ruby/ruby-2.1.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,13 +35,17 @@ SRC_URI="mirror://ruby/2.1/${MY_P}.tar.xz
LICENSE="|| ( Ruby-BSD BSD-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="berkdb debug doc examples gdbm ipv6 +rdoc rubytests socks5 ssl xemacs ncurses +readline"
+IUSE="berkdb debug doc examples gdbm ipv6 +rdoc rubytests socks5 ssl tk xemacs ncurses +readline"
RDEPEND="
berkdb? ( sys-libs/db:= )
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl:0 )
socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? (
+ dev-lang/tcl:0=[threads]
+ dev-lang/tk:0=[threads]
+ )
ncurses? ( sys-libs/ncurses:0= )
readline? ( sys-libs/readline:0 )
dev-libs/libyaml
@@ -80,12 +84,7 @@ src_prepare() {
}
src_configure() {
- local myconf=
-
- # The Tk module can no longer be built because the module code is no
- # longer compatible with newer stable versions.
- # https://bugs.gentoo.org/show_bug.cgi?id=500894
- local modules="tk"
+ local modules= myconf=
# -fomit-frame-pointer makes ruby segfault, see bug #150413.
filter-flags -fomit-frame-pointer
@@ -127,6 +126,9 @@ src_configure() {
if ! use ncurses ; then
modules="${modules},curses"
fi
+ if ! use tk ; then
+ modules="${modules},tk"
+ fi
# Provide an empty LIBPATHENV because we disable rpath but we do not
# need LD_LIBRARY_PATH by default since that breaks USE=multitarget
diff --git a/dev-lang/ruby/ruby-2.2.5.ebuild b/dev-lang/ruby/ruby-2.2.5.ebuild
index dea3baeab1f..3ba1b5ea4f2 100644
--- a/dev-lang/ruby/ruby-2.2.5.ebuild
+++ b/dev-lang/ruby/ruby-2.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -32,7 +32,7 @@ SRC_URI="mirror://ruby/2.2/${MY_P}.tar.xz
LICENSE="|| ( Ruby-BSD BSD-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="berkdb debug doc examples gdbm ipv6 jemalloc libressl +rdoc rubytests socks5 ssl xemacs ncurses +readline"
+IUSE="berkdb debug doc examples gdbm ipv6 jemalloc libressl +rdoc rubytests socks5 ssl tk xemacs ncurses +readline"
RDEPEND="
berkdb? ( sys-libs/db:= )
@@ -43,6 +43,10 @@ RDEPEND="
libressl? ( dev-libs/libressl )
)
socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? (
+ dev-lang/tcl:0=[threads]
+ dev-lang/tk:0=[threads]
+ )
ncurses? ( sys-libs/ncurses:0= )
readline? ( sys-libs/readline:0 )
dev-libs/libyaml
@@ -93,12 +97,7 @@ src_prepare() {
}
src_configure() {
- local myconf=
-
- # The Tk module can no longer be built because the module code is no
- # longer compatible with newer stable versions.
- # https://bugs.gentoo.org/show_bug.cgi?id=500894
- local modules="tk"
+ local modules= myconf=
# -fomit-frame-pointer makes ruby segfault, see bug #150413.
filter-flags -fomit-frame-pointer
@@ -140,6 +139,9 @@ src_configure() {
if ! use ncurses ; then
modules="${modules},curses"
fi
+ if ! use tk ; then
+ modules="${modules},tk"
+ fi
# Provide an empty LIBPATHENV because we disable rpath but we do not
# need LD_LIBRARY_PATH by default since that breaks USE=multitarget
diff --git a/dev-lang/ruby/ruby-2.3.1.ebuild b/dev-lang/ruby/ruby-2.3.1.ebuild
index df7be554468..28cec17e691 100644
--- a/dev-lang/ruby/ruby-2.3.1.ebuild
+++ b/dev-lang/ruby/ruby-2.3.1.ebuild
@@ -32,7 +32,7 @@ SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.xz
LICENSE="|| ( Ruby-BSD BSD-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="berkdb debug doc examples gdbm ipv6 jemalloc libressl +rdoc rubytests socks5 ssl xemacs ncurses +readline"
+IUSE="berkdb debug doc examples gdbm ipv6 jemalloc libressl +rdoc rubytests socks5 ssl tk xemacs ncurses +readline"
RDEPEND="
berkdb? ( sys-libs/db:= )
@@ -43,6 +43,10 @@ RDEPEND="
libressl? ( dev-libs/libressl )
)
socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? (
+ dev-lang/tcl:0=[threads]
+ dev-lang/tk:0=[threads]
+ )
ncurses? ( sys-libs/ncurses:0= )
readline? ( sys-libs/readline:0 )
dev-libs/libyaml
@@ -89,12 +93,7 @@ src_prepare() {
}
src_configure() {
- local myconf=
-
- # The Tk module can no longer be built because the module code is no
- # longer compatible with newer stable versions.
- # https://bugs.gentoo.org/show_bug.cgi?id=500894
- local modules="tk"
+ local modules= myconf=
# -fomit-frame-pointer makes ruby segfault, see bug #150413.
filter-flags -fomit-frame-pointer
@@ -136,6 +135,9 @@ src_configure() {
if ! use ncurses ; then
modules="${modules},curses"
fi
+ if ! use tk ; then
+ modules="${modules},tk"
+ fi
# Provide an empty LIBPATHENV because we disable rpath but we do not
# need LD_LIBRARY_PATH by default since that breaks USE=multitarget