summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-12 21:13:49 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-12 21:13:49 -0700
commit498df1dda3c6b58d6f0f66ebd5a0a456533ae868 (patch)
tree24ef68194b5226c19c70a10fd7b9f70e11a581ff /dev-lang/rust
parentvirtual/rust: drop old (diff)
downloadgentoo-498df1dda3c6b58d6f0f66ebd5a0a456533ae868.tar.gz
gentoo-498df1dda3c6b58d6f0f66ebd5a0a456533ae868.tar.bz2
gentoo-498df1dda3c6b58d6f0f66ebd5a0a456533ae868.zip
dev-lang/rust: fix typo in path
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.47.0-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/rust/rust-1.47.0-r1.ebuild b/dev-lang/rust/rust-1.47.0-r1.ebuild
index efefa29d01e1..cd258a9cb85a 100644
--- a/dev-lang/rust/rust-1.47.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.47.0-r1.ebuild
@@ -527,9 +527,10 @@ src_install() {
done
# symlinks to switch components to active rust in eselect
- dosym "../../lib/${PN}/${PV}/share/doc" "/usr/share/doc/${P}"
- dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
+ dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
+ dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
+ dosym "../../lib/${PN}/${PV}/share/doc" "/usr/share/doc/${P}"
newenvd - "50${P}" <<-_EOF_
LDPATH="${EPREFIX}/usr/lib/rust/lib"