summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-14 11:29:17 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-14 11:29:17 +0200
commit0df0f88749de1f5b840fc78f59fc4df7cf022c4a (patch)
treed691fdbb1639689713356340381bf45a89b6d4ef /dev-lang/spidermonkey/files/spidermonkey-17.0.0-unbreak-clang.patch
parentnet-mail/dovecot: security bump to 2.3.11.3 (diff)
downloadgentoo-0df0f88749de1f5b840fc78f59fc4df7cf022c4a.tar.gz
gentoo-0df0f88749de1f5b840fc78f59fc4df7cf022c4a.tar.bz2
gentoo-0df0f88749de1f5b840fc78f59fc4df7cf022c4a.zip
dev-lang/spidermonkey: fix building using clang
Closes: https://bugs.gentoo.org/737084 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/spidermonkey/files/spidermonkey-17.0.0-unbreak-clang.patch')
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-17.0.0-unbreak-clang.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/spidermonkey/files/spidermonkey-17.0.0-unbreak-clang.patch b/dev-lang/spidermonkey/files/spidermonkey-17.0.0-unbreak-clang.patch
new file mode 100644
index 000000000000..ef428e70b52f
--- /dev/null
+++ b/dev-lang/spidermonkey/files/spidermonkey-17.0.0-unbreak-clang.patch
@@ -0,0 +1,32 @@
+commit ad6d8397a05a
+Author: Dan Gohman <sunfish@mozilla.com>
+Date: Thu May 22 11:15:06 2014 -0700
+
+ Bug 1012971 - SpiderMonkey: Fix various warnings. r=nbp
+---
+ js/public/RootingAPI.h | 4 +++-
+ js/src/configure.in | 1 +
+ js/src/jit/IonFrames.h | 17 ++++++++---------
+ js/src/jit/MIR.h | 12 +++++-------
+ js/src/jit/PerfSpewer.cpp | 12 ++++++------
+ js/src/jit/RegisterSets.h | 2 +-
+ js/src/jscntxt.h | 2 +-
+ js/src/jsgcinlines.h | 4 ++--
+ js/src/jsopcode.cpp | 2 +-
+ js/src/jsscript.cpp | 6 +++---
+ js/src/shell/js.cpp | 2 +-
+ js/src/vm/ArrayBufferObject.h | 16 ++++++++--------
+ js/src/vm/TypedArrayObject.cpp | 26 +++++++++++++-------------
+ 13 files changed, 53 insertions(+), 53 deletions(-)
+
+--- old/js/src/jsopcode.cpp.orig 2013-02-11 22:33:23 UTC
++++ new/js/src/jsopcode.cpp
+@@ -6067,7 +6067,7 @@ ExpressionDecompiler::write(JSString *s)
+ bool
+ ExpressionDecompiler::quote(JSString *s, uint32_t quote)
+ {
+- return QuoteString(&sprinter, s, quote) >= 0;
++ return QuoteString(&sprinter, s, quote) != NULL;
+ }
+
+ JSAtom *