summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-20 16:03:06 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-20 16:04:05 +0200
commite3ea67130e44415ed7f556427d3782d661b53b01 (patch)
tree657ef7f2cd6d0c6bf7d1a61ee5659acc3ec171f1 /dev-lang/spidermonkey
parentdev-lang/spidermonkey: relax Rust requirement (diff)
downloadgentoo-e3ea67130e44415ed7f556427d3782d661b53b01.tar.gz
gentoo-e3ea67130e44415ed7f556427d3782d661b53b01.tar.bz2
gentoo-e3ea67130e44415ed7f556427d3782d661b53b01.zip
dev-lang/spidermonkey: clang is not needed to build spidermonkey
Closes: https://bugs.gentoo.org/740890 Closes: https://bugs.gentoo.org/743241 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/spidermonkey')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-78.2.0.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-78.2.0.ebuild b/dev-lang/spidermonkey/spidermonkey-78.2.0.ebuild
index 63a601bf3387..00c79aef9f17 100644
--- a/dev-lang/spidermonkey/spidermonkey-78.2.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-78.2.0.ebuild
@@ -7,9 +7,7 @@ PYTHON_COMPAT=( python3_{6..9} )
WANT_AUTOCONF="2.1"
-LLVM_MAX_SLOT=10
-
-inherit autotools check-reqs llvm multiprocessing python-any-r1 toolchain-funcs
+inherit autotools check-reqs multiprocessing python-any-r1 toolchain-funcs
MY_PN="mozjs"
MY_PV="${PV/_pre*}" # Handle Gentoo pre-releases
@@ -60,7 +58,7 @@ IUSE="cpu_flags_arm_neon debug +jit test"
RESTRICT="!test? ( test )"
BDEPEND="${PYTHON_DEPS}
- sys-devel/clang
+ sys-devel/llvm
>=virtual/rust-1.41.0
virtual/pkgconfig"
@@ -78,15 +76,6 @@ RDEPEND="${CDEPEND}"
S="${WORKDIR}/firefox-${MY_PV}/js/src"
-llvm_check_deps() {
- if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
- ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
- return 1
- fi
-
- einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
-}
-
python_check_deps() {
if use test ; then
has_version "dev-python/six[${PYTHON_USEDEP}]"