summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-lang/xsb
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/xsb')
-rw-r--r--dev-lang/xsb/xsb-3.6.0.ebuild76
1 files changed, 38 insertions, 38 deletions
diff --git a/dev-lang/xsb/xsb-3.6.0.ebuild b/dev-lang/xsb/xsb-3.6.0.ebuild
index f0ea2805b12f..033bb06053d6 100644
--- a/dev-lang/xsb/xsb-3.6.0.ebuild
+++ b/dev-lang/xsb/xsb-3.6.0.ebuild
@@ -81,120 +81,120 @@ src_configure() {
src_compile() {
cd "${S}"/build
- emake || die "emake failed"
+ emake
# All XSB Packages are compiled using a single Prolog engine.
# Consequently they must all be compiled using a single make job.
cd "${S}"/packages
rm -f *.xwam
- emake -j1 || die "emake packages failed"
+ emake -j1
if use curl ; then
- emake -j1 curl || die "emake curl package failed"
- emake -j1 sgml || die "emake sgml package failed"
+ emake -j1 curl
+ emake -j1 sgml
if use xml ; then
- emake -j1 xpath || die "emake xpath package failed"
+ emake -j1 xpath
fi
fi
if use mysql ; then
- emake -j1 mysql || die "emake mysql package failed"
+ emake -j1 mysql
fi
if use odbc ; then
- emake -j1 odbc || die "emake odbc package failed"
+ emake -j1 odbc
fi
if use pcre ; then
- emake -j1 pcre || die "emake pcre package failed"
+ emake -j1 pcre
fi
}
src_install() {
cd "${S}"/build
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
local XSB_INSTALL_DIR=/usr/$(get_libdir)/xsb-${PV}
- dosym ${XSB_INSTALL_DIR}/bin/xsb /usr/bin/xsb || die
+ dosym ${XSB_INSTALL_DIR}/bin/xsb /usr/bin/xsb
cd "${S}"/packages
local PACKAGES=${XSB_INSTALL_DIR}/packages
insinto ${PACKAGES}
- doins *.xwam || die
+ doins *.xwam
insinto ${PACKAGES}/chr
- doins chr/*.xwam || die
+ doins chr/*.xwam
insinto ${PACKAGES}/clpqr
- doins clpqr/*.xwam || die
+ doins clpqr/*.xwam
insinto ${PACKAGES}/gap
- doins gap/*.xwam || die
+ doins gap/*.xwam
insinto ${PACKAGES}/justify
- doins justify/*.xwam || die
- doins justify/*.H || die
+ doins justify/*.xwam
+ doins justify/*.H
insinto ${PACKAGES}/regmatch
- doins regmatch/*.xwam || die
+ doins regmatch/*.xwam
insinto ${PACKAGES}/regmatch/cc
- doins regmatch/cc/*.H || die
+ doins regmatch/cc/*.H
insinto ${PACKAGES}/slx
- doins slx/*.xwam || die
+ doins slx/*.xwam
insinto ${PACKAGES}/wildmatch
- doins wildmatch/*.xwam || die
+ doins wildmatch/*.xwam
insinto ${PACKAGES}/wildmatch/cc
- doins wildmatch/cc/*.H || die
+ doins wildmatch/cc/*.H
if use curl ; then
insinto ${PACKAGES}/curl
- doins curl/*.xwam || die
+ doins curl/*.xwam
insinto ${PACKAGES}/curl/cc
- doins curl/cc/*.H || die
+ doins curl/cc/*.H
insinto ${PACKAGES}/sgml
- doins sgml/*.xwam || die
+ doins sgml/*.xwam
insinto ${PACKAGES}/sgml/cc
- doins sgml/cc/*.H || die
+ doins sgml/cc/*.H
insinto ${PACKAGES}/sgml/cc/dtd
- doins sgml/cc/dtd/* || die
+ doins sgml/cc/dtd/*
if use xml ; then
insinto ${PACKAGES}/xpath
- doins xpath/*xwam || die
+ doins xpath/*xwam
insinto ${PACKAGES}/xpath/cc
- doins xpath/cc/*.H || die
+ doins xpath/cc/*.H
fi
fi
if use mysql || use odbc ; then
insinto ${PACKAGES}/dbdrivers
- doins dbdrivers/*.xwam || die
- doins dbdrivers/*.H || die
+ doins dbdrivers/*.xwam
+ doins dbdrivers/*.H
insinto ${PACKAGES}/dbdrivers/cc
- doins dbdrivers/cc/*.H || die
+ doins dbdrivers/cc/*.H
if use mysql ; then
insinto ${PACKAGES}/dbdrivers/mysql
- doins dbdrivers/mysql/*.xwam || die
+ doins dbdrivers/mysql/*.xwam
insinto ${PACKAGES}/dbdrivers/mysql/cc
- doins dbdrivers/mysql/cc/*.H || die
+ doins dbdrivers/mysql/cc/*.H
fi
if use odbc ; then
insinto ${PACKAGES}/dbdrivers/odbc
- doins dbdrivers/odbc/*.xwam || die
+ doins dbdrivers/odbc/*.xwam
insinto ${PACKAGES}/dbdrivers/odbc/cc
- doins dbdrivers/odbc/cc/*.H || die
+ doins dbdrivers/odbc/cc/*.H
fi
fi
if use pcre ; then
insinto ${PACKAGES}/pcre
- doins pcre/*.xwam || die
+ doins pcre/*.xwam
insinto ${PACKAGES}/pcre/cc
- doins pcre/cc/*.H || die
+ doins pcre/cc/*.H
fi
cd "${S}"
- dodoc FAQ README || die
+ dodoc FAQ README
}