summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-23 13:03:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-23 13:07:54 +0200
commit593c8e3851a9497ea32f520b92bcd520d64a9d56 (patch)
treef3e94f7b18a191438a3112c3197a9de3a9a9dbf3 /dev-lang/yasm
parentx11-misc/xbattbar: Remove old (diff)
downloadgentoo-593c8e3851a9497ea32f520b92bcd520d64a9d56.tar.gz
gentoo-593c8e3851a9497ea32f520b92bcd520d64a9d56.tar.bz2
gentoo-593c8e3851a9497ea32f520b92bcd520d64a9d56.zip
dev-lang/yasm: Remove non-updated -9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
deleted file mode 100644
index 05fea044d20c..000000000000
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-if [[ ${PV} == 9999* ]] ; then
- EGIT_REPO_URI="https://github.com/yasm/yasm.git"
- inherit autotools git-r3
-else
- SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
-HOMEPAGE="http://yasm.tortall.net/"
-
-LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
-SLOT="0"
-IUSE="nls"
-
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-DEPEND="
- nls? ( virtual/libintl )
-"
-RDEPEND="${DEPEND}
-"
-
-if [[ ${PV} == 9999* ]]; then
- BDEPEND+="
- app-text/xmlto
- app-text/docbook-xml-dtd:4.1.2
- dev-lang/python
- "
-fi
-
-src_prepare() {
- default
-
- if [[ ${PV} == 9999* ]]; then
- eautoreconf
- python modules/arch/x86/gen_x86_insn.py || die
- fi
-}
-
-src_configure() {
- local myconf=(
- CC_FOR_BUILD="$(tc-getBUILD_CC)"
- CCLD_FOR_BUILD="$(tc-getBUILD_CC)"
- --disable-warnerror
- --disable-python
- --disable-python-bindings
- $(use_enable nls)
- )
-
- econf "${myconf[@]}"
-}
-
-src_test() {
- # https://bugs.gentoo.org/718870
- emake -j1 check
-}