summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-05-13 19:11:27 -0400
committerMike Gilbert <floppym@gentoo.org>2020-05-13 19:11:27 -0400
commita969cbebb113718e1a9860143b94c8aa0558b51e (patch)
treeee108ad82e6c3e575cf8f9a259f218cabf227bf6 /dev-lang/yasm
parentdev-php/PEAR-File_SMBPasswd: keyworded 1.0.3-r1 for ppc (diff)
downloadgentoo-a969cbebb113718e1a9860143b94c8aa0558b51e.tar.gz
gentoo-a969cbebb113718e1a9860143b94c8aa0558b51e.tar.bz2
gentoo-a969cbebb113718e1a9860143b94c8aa0558b51e.zip
dev-lang/yasm: remove obsolete hacks from src_prepare
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index 5be4c7a9719b..cf48d28e8623 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -4,11 +4,11 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils python-single-r1
+inherit python-single-r1
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://github.com/yasm/yasm.git"
- inherit git-r3
+ inherit autotools git-r3
else
SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
@@ -50,16 +50,8 @@ pkg_setup() {
src_prepare() {
default
- if ! [[ ${PV} == 9999* ]]; then
- sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940
- fi
-
- # ksh doesn't grok $(xxx), makes aclocal fail
- sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
-
- eautoreconf
-
if [[ ${PV} == 9999* ]]; then
+ eautoreconf
./modules/arch/x86/gen_x86_insn.py || die
fi
}