summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-22 10:13:10 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-22 10:14:01 -0500
commit0b8397ed5feba8c1ca964a75f740b364815496c4 (patch)
tree0d3e98760ed6cc06efbfd15d24b1e729ce66a06d /dev-lang
parentmedia-gfx/k3d: remove old (diff)
downloadgentoo-0b8397ed5feba8c1ca964a75f740b364815496c4.tar.gz
gentoo-0b8397ed5feba8c1ca964a75f740b364815496c4.tar.bz2
gentoo-0b8397ed5feba8c1ca964a75f740b364815496c4.zip
dev-lang/python: pax-mark the python binary in src_install
Bug: https://bugs.gentoo.org/569908 Package-Manager: portage-2.2.27_p47
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.5.1-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.5.1-r2.ebuild b/dev-lang/python/python-3.5.1-r2.ebuild
index bf753fab3174..7f82e77d001c 100644
--- a/dev-lang/python/python-3.5.1-r2.ebuild
+++ b/dev-lang/python/python-3.5.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -254,6 +254,14 @@ src_install() {
dosym "python-${PYVER}.pc" "/usr/$(get_libdir)/pkgconfig/${abiver/${PYVER}/-${PYVER}}.pc"
fi
+ # python seems to get rebuilt in src_install (bug 569908)
+ # Work around it for now.
+ if has_version dev-libs/libffi[pax_kernel]; then
+ pax-mark E "${ED}usr/bin/${abiver}"
+ else
+ pax-mark m "${ED}usr/bin/${abiver}"
+ fi
+
use elibc_uclibc && rm -fr "${libdir}/test"
use sqlite || rm -fr "${libdir}/"{sqlite3,test/test_sqlite*}
use tk || rm -fr "${ED}usr/bin/idle${PYVER}" "${libdir}/"{idlelib,tkinter,test/test_tk*}