summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-25 18:56:50 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-25 18:58:35 -0800
commit0e00cd7cc089acdd3114b4aafc34fc921aabe058 (patch)
tree9992deca9179128675427ae2415f1bf084460d6c /dev-lang
parentdev-lang/rust: fix segfaults with system llvm:7 (diff)
downloadgentoo-0e00cd7cc089acdd3114b4aafc34fc921aabe058.tar.gz
gentoo-0e00cd7cc089acdd3114b4aafc34fc921aabe058.tar.bz2
gentoo-0e00cd7cc089acdd3114b4aafc34fc921aabe058.zip
dev-lang/rust: drop unneeded patch
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Acked-by: Thomas Deutschmann <whissi@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch32
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild1
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch b/dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch
deleted file mode 100644
index eaeab87774eb..000000000000
--- a/dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Revert "[CMake] Unconditionally add .h and .td files to target sources"
-
-This reverts commit https://github.com/llvm-mirror/llvm/commit/6fb010f388bb2cb2f00fe039123092308ac4865d.
-
-Bug: https://bugs.gentoo.org/675752#c7
---- a/src/llvm/cmake/modules/LLVMProcessSources.cmake
-+++ b/src/llvm/cmake/modules/LLVMProcessSources.cmake
-@@ -52,15 +52,16 @@ function(llvm_process_sources OUT_VAR)
- cmake_parse_arguments(ARG "" "" "ADDITIONAL_HEADERS;ADDITIONAL_HEADER_DIRS" ${ARGN})
- set(sources ${ARG_UNPARSED_ARGUMENTS})
- llvm_check_source_file_list( ${sources} )
--
-- # This adds .td and .h files to the Visual Studio solution:
-- add_td_sources(sources)
-- find_all_header_files(hdrs "${ARG_ADDITIONAL_HEADER_DIRS}")
-- if (hdrs)
-- set_source_files_properties(${hdrs} PROPERTIES HEADER_FILE_ONLY ON)
-+ if( LLVM_ENABLE_IDE )
-+ # This adds .td and .h files to the Visual Studio solution:
-+ add_td_sources(sources)
-+ find_all_header_files(hdrs "${ARG_ADDITIONAL_HEADER_DIRS}")
-+ if (hdrs)
-+ set_source_files_properties(${hdrs} PROPERTIES HEADER_FILE_ONLY ON)
-+ endif()
-+ set_source_files_properties(${ARG_ADDITIONAL_HEADERS} PROPERTIES HEADER_FILE_ONLY ON)
-+ list(APPEND sources ${ARG_ADDITIONAL_HEADERS} ${hdrs})
- endif()
-- set_source_files_properties(${ARG_ADDITIONAL_HEADERS} PROPERTIES HEADER_FILE_ONLY ON)
-- list(APPEND sources ${ARG_ADDITIONAL_HEADERS} ${hdrs})
-
- set( ${OUT_VAR} ${sources} PARENT_SCOPE )
- endfunction(llvm_process_sources)
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index bc2a6106b8ad..ea00024950f2 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -63,7 +63,6 @@ S="${WORKDIR}/${MY_P}-src"
PATCHES=(
"${FILESDIR}"/1.30.1-clippy-sysroot.patch
- "${FILESDIR}"/1.32.0-fix-configure-of-bundled-llvm.patch
"${FILESDIR}"/1.32.0-system-llvm-7-SIGSEGV.patch
)