summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Ferreira <alexandref75@gmail.com>2023-03-26 14:05:27 +0200
committerDavid Seifert <soap@gentoo.org>2023-03-26 14:05:27 +0200
commit0f664a055fc55677cda7cdf18b0e5b62978d5b8c (patch)
tree829b541522011de8722ba7e2716bc39c4093fbb7 /dev-lang
parentdev-qt/qtnetwork: update SRC_URI (diff)
downloadgentoo-0f664a055fc55677cda7cdf18b0e5b62978d5b8c.tar.gz
gentoo-0f664a055fc55677cda7cdf18b0e5b62978d5b8c.tar.bz2
gentoo-0f664a055fc55677cda7cdf18b0e5b62978d5b8c.zip
dev-lang/R: add patch for curl 8
Closes: https://bugs.gentoo.org/902993 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/R-4.2.3.ebuild3
-rw-r--r--dev-lang/R/files/R-4.2.3-curl-8.patch59
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-lang/R/R-4.2.3.ebuild b/dev-lang/R/R-4.2.3.ebuild
index f07363fe354d..5fa0d6b05b51 100644
--- a/dev-lang/R/R-4.2.3.ebuild
+++ b/dev-lang/R/R-4.2.3.ebuild
@@ -76,7 +76,8 @@ PATCHES=(
"${FILESDIR}"/R-3.6.2-no-gzip-doc.patch
"${FILESDIR}"/R-4.2.2-browser-pdf-prefs.patch
"${FILESDIR}"/R-4.2.2-isspace-without-readline.patch
- "${FILESDIR}/"R-4.2.2-parallel-rmath-h-install.patch
+ "${FILESDIR}"/R-4.2.2-parallel-rmath-h-install.patch
+ "${FILESDIR}"/R-4.2.3-curl-8.patch
)
pkg_pretend() {
diff --git a/dev-lang/R/files/R-4.2.3-curl-8.patch b/dev-lang/R/files/R-4.2.3-curl-8.patch
new file mode 100644
index 000000000000..92ee3b0d5702
--- /dev/null
+++ b/dev-lang/R/files/R-4.2.3-curl-8.patch
@@ -0,0 +1,59 @@
+https://bugs.gentoo.org/902993
+
+--- a/configure
++++ b/configure
+@@ -48533,7 +48533,7 @@
+ done
+
+ if test "x${have_libcurl}" = "xyes"; then
+-{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking if libcurl is version 7 and >= 7.28.0" >&5
++{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking if libcurl is version 7 and >= 7.28.0 or version 8" >&5
+ printf %s "checking if libcurl is version 7 and >= 7.28.0... " >&6; }
+ if test ${r_cv_have_curl728+y}
+ then :
+@@ -48551,8 +48551,10 @@
+ int main(int argc, const char * argv[])
+ {
+ #ifdef LIBCURL_VERSION_MAJOR
+-#if LIBCURL_VERSION_MAJOR > 7
++#if LIBCURL_VERSION_MAJOR > 8
+ exit(1);
++#elif LIBCURL_VERSION_MAJOR == 8
++ exit(0);
+ #elif LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR >= 28
+ exit(0);
+ #else
+--- a/m4/R.m4
++++ b/m4/R.m4
+@@ -4300,15 +4300,17 @@
+ AC_CHECK_HEADERS(curl/curl.h, [have_libcurl=yes], [have_libcurl=no])
+
+ if test "x${have_libcurl}" = "xyes"; then
+-AC_CACHE_CHECK([if libcurl is version 7 and >= 7.28.0], [r_cv_have_curl728],
++AC_CACHE_CHECK([if libcurl is version 7 and >= 7.28.0 or verion 8], [r_cv_have_curl728_8],
+ [AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
+ #include <curl/curl.h>
+ int main(int argc, const char * argv[])
+ {
+ #ifdef LIBCURL_VERSION_MAJOR
+-#if LIBCURL_VERSION_MAJOR > 7
++#if LIBCURL_VERSION_MAJOR > 8
+ exit(1);
++#elif LIBCURL_VERSION_MAJOR == 8
++ exit(0);
+ #elif LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR >= 28
+ exit(0);
+ #else
+@@ -4318,9 +4320,9 @@
+ exit(1);
+ #endif
+ }
+-]])], [r_cv_have_curl728=yes], [r_cv_have_curl728=no], [r_cv_have_curl728=no])])
++]])], [r_cv_have_curl728_8=yes], [r_cv_have_curl728_8=no], [r_cv_have_curl728_8=no])])
+ fi
+-if test "x${r_cv_have_curl728}" = xno; then
++if test "x${r_cv_have_curl728_8}" = xno; then
+ have_libcurl=no
+ fi
+