summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-25 05:16:14 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-25 05:43:04 +0100
commit362fd30287746e0e46d8a4aaa77fe6e5b4fb83ff (patch)
treee161bb4c002fe401a3497a0db6b6dd1b5bc27e2b /dev-lang
parentdev-python/ytmusicapi: Remove old (diff)
downloadgentoo-362fd30287746e0e46d8a4aaa77fe6e5b4fb83ff.tar.gz
gentoo-362fd30287746e0e46d8a4aaa77fe6e5b4fb83ff.tar.bz2
gentoo-362fd30287746e0e46d8a4aaa77fe6e5b4fb83ff.zip
dev-lang/ispc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/Manifest1
-rw-r--r--dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch16
-rw-r--r--dev-lang/ispc/files/ispc-1.19.0-gcc13.patch27
-rw-r--r--dev-lang/ispc/ispc-1.19.0.ebuild79
4 files changed, 0 insertions, 123 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index e712d186483d..b89a21202d58 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,2 +1 @@
-DIST ispc-1.19.0.tar.gz 19577782 BLAKE2B 5ad6eeeeb0bb27f2a27267a26a729693bd16250ae5e8740728290fe6ad85c7ecd4da40f316f2ca6b1447ff3a13f6949db4ed2af6ebf2c6ce6ba43620dfb1943d SHA512 140f16bc0f9e0a94853b50a5433be9196ee09b6c70a1840d400d0d201143da8cb2b1b92a857acf5856ed3410bfffd17678eb1029996f9007fe947f5ac78bf1bb
DIST ispc-1.22.0.gh.tar.gz 19618494 BLAKE2B 0dae95d792e4d629b38a9775c2c600131374c69dfa086d6a67100e40e5005ef054b9a651f418e0452a19ee4e64ffd830bfaa787b14e706473e8fab1d2380f0fd SHA512 4436ea37003b4cbfefcbf4c18212d0e98536243ae8f01053817d579e04205a4dcd4ab7b2b282fec99fc617009fdbea340b348cf4a2134240d2fcfc6bcaf6b60c
diff --git a/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch b/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch
deleted file mode 100644
index 19a19e871ee7..000000000000
--- a/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -598,11 +598,8 @@ else()
- target_link_libraries(${PROJECT_NAME} pthread tinfo.a curses.a)
- else()
- find_package(Curses REQUIRED)
-- if (CURSES_EXTRA_LIBRARY)
-- # this contains the tinfo library, if found
-- target_link_libraries(${PROJECT_NAME} ${CURSES_EXTRA_LIBRARY})
-- endif()
-- target_link_libraries(${PROJECT_NAME} pthread ${CURSES_CURSES_LIBRARY})
-+ set(CURSES_NEED_NCURSES ON)
-+ target_link_libraries(${PROJECT_NAME} pthread ${CURSES_LIBRARIES})
- endif()
- endif()
-
diff --git a/dev-lang/ispc/files/ispc-1.19.0-gcc13.patch b/dev-lang/ispc/files/ispc-1.19.0-gcc13.patch
deleted file mode 100644
index e2bae38ae581..000000000000
--- a/dev-lang/ispc/files/ispc-1.19.0-gcc13.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://bugs.gentoo.org/895572
-https://github.com/ispc/ispc/commit/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9
-
-From ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9 Mon Sep 17 00:00:00 2001
-From: Luya Tshimbalanga <luya@fedoraproject.org>
-Date: Tue, 28 Feb 2023 17:20:21 -0800
-Subject: [PATCH] Fix build with GCC 13 and possibly Clang 15
-
-This fix add missing <cstdint> include to handle "uint32_t".
---- a/src/target_registry.h
-+++ b/src/target_registry.h
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2019-2021, Intel Corporation
-+ Copyright (c) 2019-2023, Intel Corporation
- All rights reserved.
-
- Redistribution and use in source and binary forms, with or without
-@@ -40,6 +40,7 @@
- #include "bitcode_lib.h"
-
- #include <bitset>
-+#include <cstdint>
- #include <map>
- #include <vector>
-
-
diff --git a/dev-lang/ispc/ispc-1.19.0.ebuild b/dev-lang/ispc/ispc-1.19.0.ebuild
deleted file mode 100644
index 42ebe7e712a4..000000000000
--- a/dev-lang/ispc/ispc-1.19.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-LLVM_MAX_SLOT=15
-inherit cmake python-any-r1 llvm
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.io/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ispc/ispc.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="<sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):="
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-alternatives/yacc
- app-alternatives/lex
- ${PYTHON_DEPS}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.19.0-curses-cmake.patch
- "${FILESDIR}"/${P}-gcc13.patch
-)
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- if use amd64; then
- # On amd64 systems, build system enables x86/i686 build too.
- # This ebuild doesn't even have multilib support, nor need it.
- # https://bugs.gentoo.org/730062
- ewarn "Removing auto-x86 build on amd64"
- sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DARM_ENABLED=$(usex arm)
- -DCMAKE_SKIP_RPATH=ON
- -DISPC_INCLUDE_EXAMPLES=OFF
- -DISPC_INCLUDE_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- # Inject path to prevent using system ispc
- PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/bin/ispc
- einstalldocs
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
-}