summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-01-16 09:10:50 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-16 09:12:19 +0100
commit3fcb3f8439971af4083cc765d54fd3fc7e310db7 (patch)
tree146e11d1f8b067a6180a4723f8e8181361786089 /dev-lang
parentnet-fs/samba: Add AES acceleration is cpu_flags_x86_aes set (diff)
downloadgentoo-3fcb3f8439971af4083cc765d54fd3fc7e310db7.tar.gz
gentoo-3fcb3f8439971af4083cc765d54fd3fc7e310db7.tar.bz2
gentoo-3fcb3f8439971af4083cc765d54fd3fc7e310db7.zip
dev-lang/ammonite-repl-bin: add 2.5.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ammonite-repl-bin/Manifest1
-rw-r--r--dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.5.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-lang/ammonite-repl-bin/Manifest b/dev-lang/ammonite-repl-bin/Manifest
index 6ea487f90c61..d7138c6c4e43 100644
--- a/dev-lang/ammonite-repl-bin/Manifest
+++ b/dev-lang/ammonite-repl-bin/Manifest
@@ -1,2 +1,3 @@
DIST ammonite-2.4.1 48567893 BLAKE2B d7096170c1072aabdc2b4374fdc89bee390a04fc01748c985eeb8be9cb2bc5d09334644c21b3bb4d2eab436b7df1ff8c915a26cde76d38a5765b29673d09ccf9 SHA512 7e65c7789c42e1ac23455dd27702baf80c3f7c554403f3a34bb939283328b719212af0a824152875e09a6120cc6c67405c1dce0e5da1d07e4e185002ae4672ca
DIST ammonite-2.5.0 48405047 BLAKE2B 5d3506a89f59adde33447f22ed1a480161c6a635cd4710320f7ac66991e6171e5addc9e5ba62013f95b4e4f969899bce5b009853c36e0e966bff41c6afa69041 SHA512 8878a53b42db5edfe5a489c6abba16d985c94adc6b59ce8cac077a4e1eb7b9ad40be4bc1c27a28bbb277a47bab581a60b28ccded90081d216194d45086701550
+DIST ammonite-repl-bin-2.5.1 48408804 BLAKE2B 20d9738229c054e94393d50c86996a8a3fb8ecac1bfebe4b61d989edf0921c027bd5c1b48304bd69d9410c84debe9439aa315678fa9e4146bda845583c829fd9 SHA512 bb45d8790bf5ae853d22501b47e20e532b8a78f61dc63fbeb052b9a704befe1facb5572a3cdf9f7329f1dbca1637e9f191b10be761cb657e293506fb3fdc749c
diff --git a/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.5.1.ebuild b/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.5.1.ebuild
new file mode 100644
index 000000000000..7da31b8ae7c2
--- /dev/null
+++ b/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+SCALA_VERSION="2.13"
+
+DESCRIPTION="Scala language-based scripting and REPL"
+HOMEPAGE="https://ammonite.io/"
+SRC_URI="https://github.com/lihaoyi/Ammonite/releases/download/${PV}/${SCALA_VERSION}-${PV} -> ${P}"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ newbin "${DISTDIR}"/${P} amm
+}