summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-10-30 20:51:16 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-10-30 22:21:41 -0400
commit594654d60dffccc3bc6bacbe1e02aeaf976ecb9d (patch)
tree999d760eb3ab33a31b8bc454f0806a9e15d42a93 /dev-lang
parentdev-lang/php: remove redundant "if use firebird" check. (diff)
downloadgentoo-594654d60dffccc3bc6bacbe1e02aeaf976ecb9d.tar.gz
gentoo-594654d60dffccc3bc6bacbe1e02aeaf976ecb9d.tar.bz2
gentoo-594654d60dffccc3bc6bacbe1e02aeaf976ecb9d.zip
dev-lang/php: remove redundant "if use odbc" check.
The use_with function doesn't do anything if its USE flag is disabled, so there's no reason to wrap use_with in "if use...". Gentoo-Bug: 551526 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/php-5.6.15.ebuild6
-rw-r--r--dev-lang/php/php-7.0.0_rc5.ebuild6
2 files changed, 4 insertions, 8 deletions
diff --git a/dev-lang/php/php-5.6.15.ebuild b/dev-lang/php/php-5.6.15.ebuild
index 43c63358dfd4..b886802fc3d3 100644
--- a/dev-lang/php/php-5.6.15.ebuild
+++ b/dev-lang/php/php-5.6.15.ebuild
@@ -463,10 +463,8 @@ src_configure() {
fi
# ODBC support
- if use odbc ; then
- my_conf+="
- $(use_with odbc unixODBC ${EPREFIX}/usr)"
- fi
+ my_conf+="
+ $(use_with odbc unixODBC ${EPREFIX}/usr)"
if use iodbc ; then
my_conf+="
diff --git a/dev-lang/php/php-7.0.0_rc5.ebuild b/dev-lang/php/php-7.0.0_rc5.ebuild
index 12bfcee2595e..481989304c68 100644
--- a/dev-lang/php/php-7.0.0_rc5.ebuild
+++ b/dev-lang/php/php-7.0.0_rc5.ebuild
@@ -440,10 +440,8 @@ src_configure() {
fi
# ODBC support
- if use odbc ; then
- my_conf+="
- $(use_with odbc unixODBC ${EPREFIX}/usr)"
- fi
+ my_conf+="
+ $(use_with odbc unixODBC ${EPREFIX}/usr)"
if use iodbc ; then
my_conf+="