summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-26 23:39:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-26 23:40:47 +0200
commit5fa56a38ce0a5ae9d983c795fe98cf2245726de1 (patch)
tree5098c3ebd41f299b762e083893e505506e2aca4e /dev-lang
parentmedia-libs/ffmpegsource: add 2.40 (diff)
downloadgentoo-5fa56a38ce0a5ae9d983c795fe98cf2245726de1.tar.gz
gentoo-5fa56a38ce0a5ae9d983c795fe98cf2245726de1.tar.bz2
gentoo-5fa56a38ce0a5ae9d983c795fe98cf2245726de1.zip
dev-lang/julia: filter LTO (type mismatch)
Closes: https://bugs.gentoo.org/855602 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/julia/julia-1.7.1-r4.ebuild5
-rw-r--r--dev-lang/julia/julia-1.7.3.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/julia/julia-1.7.1-r4.ebuild b/dev-lang/julia/julia-1.7.1-r4.ebuild
index 64c2c07f71c4..1ddfaf72dbc2 100644
--- a/dev-lang/julia/julia-1.7.1-r4.ebuild
+++ b/dev-lang/julia/julia-1.7.1-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit llvm pax-utils toolchain-funcs
+inherit flag-o-matic llvm pax-utils toolchain-funcs
# correct versions for stdlibs are in deps/checksums
# for everything else, run with network-sandbox and wait for the crash
@@ -110,6 +110,9 @@ src_prepare() {
}
src_configure() {
+ # bug #855602
+ filter-lto
+
use system-llvm && ewarn "You have enabled system-llvm. This is unsupported by upstream and may not work."
# julia does not play well with the system versions of libuv
diff --git a/dev-lang/julia/julia-1.7.3.ebuild b/dev-lang/julia/julia-1.7.3.ebuild
index 39455ca05597..1b2d16111014 100644
--- a/dev-lang/julia/julia-1.7.3.ebuild
+++ b/dev-lang/julia/julia-1.7.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit llvm pax-utils toolchain-funcs
+inherit flag-o-matic llvm pax-utils toolchain-funcs
# correct versions for stdlibs are in deps/checksums
# for everything else, run with network-sandbox and wait for the crash
@@ -123,6 +123,9 @@ src_prepare() {
}
src_configure() {
+ # bug #855602
+ filter-lto
+
use system-llvm && ewarn "You have enabled system-llvm. This is unsupported by upstream and may not work."
# julia does not play well with the system versions of libuv