summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2016-01-01 22:20:01 +0100
committerJauhien Piatlicki <jauhien@gentoo.org>2016-01-01 22:26:20 +0100
commit692645a4b3092a051a812c0326d64c1f4e765887 (patch)
tree17cc4d928ed120c72320a5c1e31b90f9a4b178db /dev-lang
parentgnome-extra/eiciel: Drop old (diff)
downloadgentoo-692645a4b3092a051a812c0326d64c1f4e765887.tar.gz
gentoo-692645a4b3092a051a812c0326d64c1f4e765887.tar.bz2
gentoo-692645a4b3092a051a812c0326d64c1f4e765887.zip
dev-lang/rust-bin: version bump, sync with gentoo-rust overlay
Gentoo-Bug: 566148 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/Manifest2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.5.0.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-lang/rust-bin/Manifest b/dev-lang/rust-bin/Manifest
index db670bf05179..796530a9c1ff 100644
--- a/dev-lang/rust-bin/Manifest
+++ b/dev-lang/rust-bin/Manifest
@@ -1,3 +1,5 @@
+DIST rust-1.5.0-i686-unknown-linux-gnu.tar.gz 97897323 SHA256 ee45a91c5b1b3542fc349c743667216dec52ea924166ced90675500baf2c42cd SHA512 1fdbb197fc2f28c846da2099e5c671fd165236a0e611eadd9faf07cdd8a3312f0085d992e97da1f97e1e10fb3d9f4d06215208242349a7d7857008d003495eb2 WHIRLPOOL d3a4dd5e002cd85d71648822274e8d4e1085618c38efdda602ab2afe647ad0415360c84fd18a5e1cda544ae54d18daa3a6e6ecd92b7529fb5263a8edcd3577c3
+DIST rust-1.5.0-x86_64-unknown-linux-gnu.tar.gz 97177085 SHA256 60b83f74d882ce2ba5bc979b5b0589dca56659f215b3259e7188fed8c50aac9d SHA512 2ccb6fcb7479ce6d7a5c9a55b3dde7dacc723012a8d8065f431492c7060aeb3dcf3c5df120a583aa890c659b08cbd9cb6df0846e936fdb808afb5efb2410e3b6 WHIRLPOOL bd20965ba143ef95ea7da378f8b312bc1f6340635fcbc9ef8c351bf2f5488825d4f96f3b43d5f88dba8587273ea73586e69c5f5adaf88f32fe01f5ffe5100abb
DIST rustc-1.2.0-i686-unknown-linux-gnu.tar.gz 89840371 SHA256 f4c1692479314d63ee67914ec2065778c39ca4912f191a7894caf5264802b4fa SHA512 c89e6fac05c79755db7c15a275ac2a11d781fda10f6851ff13f0dce314f9a373bd5b79d0e1da0780071ce959693d4f08c33e3d18abbabe802922679d1e25a6b6 WHIRLPOOL 56c0636ecdc745fcdb41b77037486ba04c11b6a08568a0ada962687ead31bbd2c8f360894e629428fde4e5e3204d355e402d4a3651c4b13d0422e16beaec9f60
DIST rustc-1.2.0-x86_64-unknown-linux-gnu.tar.gz 88888977 SHA256 32fb262ba9da26a6d5ad9b2ca420fb56d97af8f86acb5cda2e85b7e7c33f6dcc SHA512 ea87a2c0e05d3f7e7c738320fd08b53055f76703526846b87b885e7abbd320b2f393b9328daa1ca04e9cb545e906c5750b6dcede2ede23323aeab8a8b096ccfd WHIRLPOOL e82ed578218ce19b4a7ca5b9d4c842c5546b5daa6aa3be162393fc0ca7148cf245bb7a79719b10ea7bf43952f8908a6355eea9070f027fcd5f1d70caa37c9931
DIST rustc-1.3.0-i686-unknown-linux-gnu.tar.gz 90445379 SHA256 7a3add3d229047bc68b929ba7b5f5d5796333f29e160c18c2a0ff24f643fab6b SHA512 afd001c1c285f12c13c0a9ecf0788f47ab72f069c1e1c5ec568973691ef2223c075fb99324e8245012e8a21003ea4fc63d874de99b95065aa9d09081798e09d5 WHIRLPOOL d273387d6eea540bf3a4bff96b5f754537ed265348661d412d37280f6d89fc726ed46fa03995b26eb444ac18e6c41f07d23c3c6844c7aaa00d2cc3970bad2f40
diff --git a/dev-lang/rust-bin/rust-bin-1.5.0.ebuild b/dev-lang/rust-bin/rust-bin-1.5.0.ebuild
new file mode 100644
index 000000000000..aef5ebe7f123
--- /dev/null
+++ b/dev-lang/rust-bin/rust-bin-1.5.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+MY_P="rust-${PV}"
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="amd64? ( http://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux-gnu.tar.gz )
+ x86? ( http://static.rust-lang.org/dist/${MY_P}-i686-unknown-linux-gnu.tar.gz )"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="stable"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+ !dev-lang/rust:0
+"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="
+ opt/${P}/bin/rustc-bin-${PV}
+ opt/${P}/bin/rustdoc-bin-${PV}
+ opt/${P}/lib/*.so
+ opt/${P}/lib/rustlib/*/lib/*.so
+"
+
+src_unpack() {
+ default
+
+ local postfix
+ use amd64 && postfix=x86_64-unknown-linux-gnu
+ use x86 && postfix=i686-unknown-linux-gnu
+ mv "${WORKDIR}/${MY_P}-${postfix}" "${S}" || die
+}
+
+src_install() {
+ local std=$(grep 'std' ./components)
+ local components="rustc,${std}"
+ use doc && components="${components},rust-docs"
+ ./install.sh \
+ --components="${components}" \
+ --disable-verify \
+ --prefix="${D}/opt/${P}" \
+ --mandir="${D}/usr/share/${P}/man" \
+ --disable-ldconfig \
+ || die
+
+ local rustc=rustc-bin-${PV}
+ local rustdoc=rustdoc-bin-${PV}
+ local rustgdb=rust-gdb-bin-${PV}
+
+ mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
+ mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
+ mv "${D}/opt/${P}/bin/rust-gdb" "${D}/opt/${P}/bin/${rustgdb}" || die
+
+ dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
+ dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
+ dosym "/opt/${P}/bin/${rustgdb}" "/usr/bin/${rustgdb}"
+
+ cat <<-EOF > "${T}"/50${P}
+ LDPATH="/opt/${P}/lib"
+ MANPATH="/usr/share/${P}/man"
+ EOF
+ doenvd "${T}"/50${P}
+
+ cat <<-EOF > "${T}/provider-${P}"
+ /usr/bin/rustdoc
+ /usr/bin/rust-gdb
+ EOF
+ dodir /etc/env.d/rust
+ insinto /etc/env.d/rust
+ doins "${T}/provider-${P}"
+}
+
+pkg_postinst() {
+ eselect rust update --if-unset
+
+ elog "Rust installs a helper script for calling GDB now,"
+ elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV},"
+
+ if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+ elog "install app-emacs/rust-mode to get emacs support for rust."
+ fi
+
+ if has_version app-editors/gvim || has_version app-editors/vim; then
+ elog "install app-vim/rust-mode to get vim support for rust."
+ fi
+
+ if has_version 'app-shells/zsh'; then
+ elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+ fi
+}
+
+pkg_postrm() {
+ eselect rust unset --if-invalid
+}