summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-06-24 23:56:06 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-06-24 23:56:16 +0100
commit8bfac183230c31f95a3ae809d8647f87eacfae38 (patch)
treee97a56a0d35d939764a5e14c61cfade8859d65ce /dev-lang
parentnet-im/webex: Version bump (diff)
downloadgentoo-8bfac183230c31f95a3ae809d8647f87eacfae38.tar.gz
gentoo-8bfac183230c31f95a3ae809d8647f87eacfae38.tar.bz2
gentoo-8bfac183230c31f95a3ae809d8647f87eacfae38.zip
dev-lang/erlang: add -fno-strict-aliasing workaround
Reported-by: Jonathan Davies Closes: https://bugs.gentoo.org/797886 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/erlang-24.0.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/erlang/erlang-24.0.2.ebuild b/dev-lang/erlang/erlang-24.0.2.ebuild
index 01313ebc6b11..40a0d0afa216 100644
--- a/dev-lang/erlang/erlang-24.0.2.ebuild
+++ b/dev-lang/erlang/erlang-24.0.2.ebuild
@@ -54,6 +54,11 @@ src_prepare() {
default
tc-export AR CPP CXX LD
+
+ # bug #797886: erlang's VM does unsafe casts for ints
+ # to pointers and back. This breaks on gcc-11 -flto.
+ append-flags -fno-strict-aliasing
+
./otp_build autoconf || die
}