summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-12-22 17:09:01 +0800
committerJason Zaman <perfinion@gentoo.org>2015-12-22 17:09:23 +0800
commit97c69c36ab7c791eb050317c48967b14d4bbcf99 (patch)
tree5cab169b9b2efc474f22183db7632da46f07d577 /dev-lang
parentapp-emulation/libvirt: x86 stable wrt bug #568870 (diff)
downloadgentoo-97c69c36ab7c791eb050317c48967b14d4bbcf99.tar.gz
gentoo-97c69c36ab7c791eb050317c48967b14d4bbcf99.tar.bz2
gentoo-97c69c36ab7c791eb050317c48967b14d4bbcf99.zip
dev-lang/mono: do not call paxctl directly
paxmark.sh should be used instead which follows XT/PT marks correctly Gentoo-Bug: https://bugs.gentoo.org/532244 Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/mono-4.2.1.124.ebuild5
-rw-r--r--dev-lang/mono/mono-4.2.2.10.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/mono/mono-4.2.1.124.ebuild b/dev-lang/mono/mono-4.2.1.124.ebuild
index 83b5c4b3a923..ee9aa1d3cd65 100644
--- a/dev-lang/mono/mono-4.2.1.124.ebuild
+++ b/dev-lang/mono/mono-4.2.1.124.ebuild
@@ -51,13 +51,14 @@ pkg_setup() {
src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTEC is enable. #286280
+ # get killed in the build proces when MPROTECT is enable. #286280
# RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
# issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi
# mono build system can fail otherwise
diff --git a/dev-lang/mono/mono-4.2.2.10.ebuild b/dev-lang/mono/mono-4.2.2.10.ebuild
index 83b5c4b3a923..ee9aa1d3cd65 100644
--- a/dev-lang/mono/mono-4.2.2.10.ebuild
+++ b/dev-lang/mono/mono-4.2.2.10.ebuild
@@ -51,13 +51,14 @@ pkg_setup() {
src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTEC is enable. #286280
+ # get killed in the build proces when MPROTECT is enable. #286280
# RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."
# issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi
# mono build system can fail otherwise