summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-02 03:24:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-11-02 04:25:32 -0400
commita44a7c839ea3519df999b99fcf2e86fd8cd15e8e (patch)
treeadd5060ad655b5eff107dc357041249f77c9b75e /dev-lang
parentdev-lang/inform: add gitlab remote-id (diff)
downloadgentoo-a44a7c839ea3519df999b99fcf2e86fd8cd15e8e.tar.gz
gentoo-a44a7c839ea3519df999b99fcf2e86fd8cd15e8e.tar.bz2
gentoo-a44a7c839ea3519df999b99fcf2e86fd8cd15e8e.zip
dev-lang/inform: add 6.35_p4, EAPI5->8
May still need work, not familiar with this package and it changed a few things around in the last 7 years. Bug: https://bugs.gentoo.org/819627 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/inform/Manifest1
-rw-r--r--dev-lang/inform/inform-6.35_p4.ebuild51
-rw-r--r--dev-lang/inform/metadata.xml3
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-lang/inform/Manifest b/dev-lang/inform/Manifest
index fc608436e98c..affbf7ed9449 100644
--- a/dev-lang/inform/Manifest
+++ b/dev-lang/inform/Manifest
@@ -1 +1,2 @@
DIST inform-6.33.1-b2.tar.gz 1822648 BLAKE2B e2ea59aa310b2f0122d1b834d98b0b827b945a8031a3e61c70bf502f7a746f43b81035cc22805ab351abf6f9df9ba898ea6ea83da863ef9aa313840ed974d725 SHA512 12cc10b7dae4118600a4d19d0aa44c3a7c93dfc8aa17bd56df7b9237f21df0ae99db6840eefaa5b11ff346369c6f6f2f128167b3479c8f540c29e3e36666c368
+DIST inform-6.35-r4.tar.gz 2307089 BLAKE2B 9864324fe29fe920e226a239f92f327678ed796e5f5a27b3814f62b1158673b2c14d6771abd7af6f9743bb0949c4c6de75a6b591337b0e99196f8ab4d9f0c9f7 SHA512 c30c7067786845e0c77783f7a03a151ae1238978f648f6036fe9535a33662c76abc11db21bab00fe60c4742cd4da46e4674081711b9b3852520bfb14c1b068a6
diff --git a/dev-lang/inform/inform-6.35_p4.ebuild b/dev-lang/inform/inform-6.35_p4.ebuild
new file mode 100644
index 000000000000..3b193b357e92
--- /dev/null
+++ b/dev-lang/inform/inform-6.35_p4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-r}"
+
+DESCRIPTION="Design system for interactive fiction"
+HOMEPAGE="https://www.inform-fiction.org/"
+SRC_URI="https://ifarchive.org/if-archive/infocom/compilers/inform6/source/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Artistic-2 Inform"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="emacs tools"
+# non-interactive tests use ruby, seem broken, and return true even on failure
+RESTRICT="test"
+
+RDEPEND="
+ tools? (
+ dev-lang/perl
+ dev-perl/DateTime
+ )"
+PDEPEND="emacs? ( app-emacs/inform-mode )"
+
+src_compile() {
+ tc-export CC
+
+ emake PREFIX="${EPREFIX}"/usr OPTS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ local emakeargs=(
+ PREFIX="${ED}"/usr
+ REAL_PREFIX="${EPREFIX}"/usr
+ MANDIR="${ED}"/usr/share/man/man1
+ PUNYDOCS="${ED}"/usr/share/doc/${PF}/punyinform
+ PUNYTESTS="${T}" # don't install tests
+ )
+
+ emake -j1 "${emakeargs[@]}" install
+
+ dodoc AUTHORS NEWS README.md VERSION docs/README*
+
+ use tools || rm "${ED}"/usr/bin/*blorb* || die
+
+ find "${ED}"/usr/share/doc \( -name Makefile -o -name 'custom.*' \) -delete || die
+}
diff --git a/dev-lang/inform/metadata.xml b/dev-lang/inform/metadata.xml
index e94045a89808..20f18c5cfb1b 100644
--- a/dev-lang/inform/metadata.xml
+++ b/dev-lang/inform/metadata.xml
@@ -5,6 +5,9 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="tools">Install blorbtools for manipulating Blorb files</flag>
+ </use>
<upstream>
<remote-id type="gitlab">DavidGriffith/inform6unix</remote-id>
</upstream>