summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-07-03 22:51:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-07-03 22:51:53 +0100
commitccc69bc760de2a0cba00f6123349dc4f380b4abb (patch)
treeaddc874bd9316a3626249c4ed3407e052cc45245 /dev-lang
parentapp-admin/salt: Revbump to 2016.11.9-r2, pycryptodome (bug #611576) (diff)
downloadgentoo-ccc69bc760de2a0cba00f6123349dc4f380b4abb.tar.gz
gentoo-ccc69bc760de2a0cba00f6123349dc4f380b4abb.tar.bz2
gentoo-ccc69bc760de2a0cba00f6123349dc4f380b4abb.zip
dev-lang/squirrel: declare used CMake variables, bug #659880
portage's QA check complains: > One or more CMake variables were not used by the project: > DISABLE_STATIC > LONG_OUTPUT_NAMES The warning is misleading. Variables are used but not declared as 'options()'s. This change tweaks the declaration. Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/659880 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/squirrel/files/squirrel-3.1-declare-options.patch10
-rw-r--r--dev-lang/squirrel/squirrel-3.1.ebuild6
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-lang/squirrel/files/squirrel-3.1-declare-options.patch b/dev-lang/squirrel/files/squirrel-3.1-declare-options.patch
new file mode 100644
index 000000000000..11bdbf107ced
--- /dev/null
+++ b/dev-lang/squirrel/files/squirrel-3.1-declare-options.patch
@@ -0,0 +1,10 @@
+Explicitly declare used CMake options
+
+Bug: https://bugs.gentoo.org/659880
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1 +1,4 @@
++option(DISABLE_STATIC "Avoid building/installing static libraries.")
++option(LONG_OUTPUT_NAMES "Use longer names for binaries and libraries: squirrel3 (not sq).")
++
+ if(MSVC)
diff --git a/dev-lang/squirrel/squirrel-3.1.ebuild b/dev-lang/squirrel/squirrel-3.1.ebuild
index 4a149398eb44..761fd5c1da25 100644
--- a/dev-lang/squirrel/squirrel-3.1.ebuild
+++ b/dev-lang/squirrel/squirrel-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,6 +17,10 @@ IUSE="examples static-libs"
RDEPEND=""
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-declare-options.patch
+)
+
src_configure() {
local mycmakeargs=(
-DINSTALL_LIB_DIR="$(get_libdir)" \