summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 10:36:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 11:55:46 +0100
commitcd3f25deb13cf4d6c9d721d515dbf772a988426f (patch)
tree423ea2268525779097c812fd1bef71091c26dc89 /dev-lang
parentsys-apps/openrc: arm stable wrt bug #704600 (diff)
downloadgentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.tar.gz
gentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.tar.bz2
gentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.zip
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/hy/hy-0.14.0.ebuild4
-rw-r--r--dev-lang/hy/hy-0.15.0.ebuild4
-rw-r--r--dev-lang/hy/hy-0.16.0.ebuild4
-rw-r--r--dev-lang/hy/hy-0.17.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.37.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.38.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.39.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.40.0-r1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.40.0.ebuild4
9 files changed, 18 insertions, 18 deletions
diff --git a/dev-lang/hy/hy-0.14.0.ebuild b/dev-lang/hy/hy-0.14.0.ebuild
index c7f7b5a7c07e..08a36201b85e 100644
--- a/dev-lang/hy/hy-0.14.0.ebuild
+++ b/dev-lang/hy/hy-0.14.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=(python{2_7,3_6})
inherit distutils-r1 eutils
DESCRIPTION="A LISP dialect running in python"
diff --git a/dev-lang/hy/hy-0.15.0.ebuild b/dev-lang/hy/hy-0.15.0.ebuild
index ad923928b2f8..7b8d1d4f5021 100644
--- a/dev-lang/hy/hy-0.15.0.ebuild
+++ b/dev-lang/hy/hy-0.15.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=(python{2_7,3_6})
inherit distutils-r1 eutils
DESCRIPTION="A LISP dialect running in python"
diff --git a/dev-lang/hy/hy-0.16.0.ebuild b/dev-lang/hy/hy-0.16.0.ebuild
index 4c1b092914ee..b87fe0151310 100644
--- a/dev-lang/hy/hy-0.16.0.ebuild
+++ b/dev-lang/hy/hy-0.16.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+PYTHON_COMPAT=(python{2_7,3_6,3_7})
inherit distutils-r1 eutils
DESCRIPTION="A LISP dialect running in python"
diff --git a/dev-lang/hy/hy-0.17.0.ebuild b/dev-lang/hy/hy-0.17.0.ebuild
index 53cd1fd34d5c..8ca5efefbed7 100644
--- a/dev-lang/hy/hy-0.17.0.ebuild
+++ b/dev-lang/hy/hy-0.17.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+PYTHON_COMPAT=(python{2_7,3_6,3_7})
inherit distutils-r1 eutils
DESCRIPTION="A LISP dialect running in python"
diff --git a/dev-lang/rust/rust-1.37.0.ebuild b/dev-lang/rust/rust-1.37.0.ebuild
index e3a96e80453d..31a203e3dd3b 100644
--- a/dev-lang/rust/rust-1.37.0.ebuild
+++ b/dev-lang/rust/rust-1.37.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.38.0.ebuild b/dev-lang/rust/rust-1.38.0.ebuild
index 87dac341a853..a2cbb5dcb9cd 100644
--- a/dev-lang/rust/rust-1.38.0.ebuild
+++ b/dev-lang/rust/rust-1.38.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.39.0.ebuild b/dev-lang/rust/rust-1.39.0.ebuild
index aba514ead68d..b221916b0b34 100644
--- a/dev-lang/rust/rust-1.39.0.ebuild
+++ b/dev-lang/rust/rust-1.39.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.40.0-r1.ebuild b/dev-lang/rust/rust-1.40.0-r1.ebuild
index 5618c967e965..e204b4c08023 100644
--- a/dev-lang/rust/rust-1.40.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.40.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
diff --git a/dev-lang/rust/rust-1.40.0.ebuild b/dev-lang/rust/rust-1.40.0.ebuild
index 8d3916ffc831..9f1b9c45eddb 100644
--- a/dev-lang/rust/rust-1.40.0.ebuild
+++ b/dev-lang/rust/rust-1.40.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs