summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-05 04:52:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-05 05:53:37 +0100
commite53e739aef464b4b374305d412b5f8940e03720c (patch)
treedb325f988172fba1c86743b72094f2036490293c /dev-lang
parentdev-perl/WWW-Form-UrlEncoded-XS: Stabilize 0.260.0 ppc, #828228 (diff)
downloadgentoo-e53e739aef464b4b374305d412b5f8940e03720c.tar.gz
gentoo-e53e739aef464b4b374305d412b5f8940e03720c.tar.bz2
gentoo-e53e739aef464b4b374305d412b5f8940e03720c.zip
dev-lang/neko: new package; add version 2.3.0
Closes: https://github.com/gentoo/gentoo/pull/20470 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/neko/Manifest1
-rw-r--r--dev-lang/neko/metadata.xml24
-rw-r--r--dev-lang/neko/neko-2.3.0.ebuild49
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-lang/neko/Manifest b/dev-lang/neko/Manifest
new file mode 100644
index 000000000000..6072317ae8ce
--- /dev/null
+++ b/dev-lang/neko/Manifest
@@ -0,0 +1 @@
+DIST neko-2.3.0.tar.gz 514044 BLAKE2B 1214fd15e0bff9df3f0bb3f4c856134772f42da5740adc260051bea6e0203e2e37db852b97114ddeef58d8320313dd01875918dee1a001833a3b9ca7d7c3c512 SHA512 fec51bed0c5500561635656c7456f3da0599aa6a47a25efe739b3c51f9cdded4a8824ed14ab67bab0905d9082cf6f06b3a76c868cb1b61d440957bcd9fd3f3d2
diff --git a/dev-lang/neko/metadata.xml b/dev-lang/neko/metadata.xml
new file mode 100644
index 000000000000..471f38415bed
--- /dev/null
+++ b/dev-lang/neko/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <use>
+ <flag name="apache">Build Apache modules</flag>
+ </use>
+ <longdescription lang="en">
+ Neko is a high-level dynamically typed programming language. It can be
+ used as an embedded scripting language. It has been designed to provide
+ a common runtime for several different languages. Learning and using
+ Neko is very easy. You can easily extend the language with C libraries.
+ You can also write generators from your own language to Neko and then
+ use the Neko Runtime to compile, run, and access existing libraries.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/HaxeFoundation/neko/issues/</bugs-to>
+ <remote-id type="github">HaxeFoundation/neko</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lang/neko/neko-2.3.0.ebuild b/dev-lang/neko/neko-2.3.0.ebuild
new file mode 100644
index 000000000000..307509336fb3
--- /dev/null
+++ b/dev-lang/neko/neko-2.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Neko is a high-level dynamically typed programming language"
+HOMEPAGE="https://nekovm.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/${PN}.git"
+else
+ # 2.3.0 -> 2-3-0
+ MY_PV="${PV//./-}"
+ SRC_URI="https://github.com/HaxeFoundation/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="apache mysql sqlite ssl"
+
+DEPEND="
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ sys-libs/zlib:=
+ apache? ( www-servers/apache:2 )
+ mysql? ( dev-db/mysql:* )
+ sqlite? ( dev-db/sqlite )
+ ssl? ( dev-libs/openssl )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DRUN_LDCONFIG=OFF
+ -DWITH_NEKOML=ON
+ -DWITH_REGEXP=ON
+ -DWITH_UI=OFF
+ -DWITH_APACHE=$(usex apache)
+ -DWITH_MYSQL=$(usex mysql)
+ -DWITH_SQLITE=$(usex sqlite)
+ -DWITH_SSL=$(usex ssl)
+ )
+ cmake_src_configure
+}