summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-11 12:02:30 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-11 12:02:30 +1200
commite9b817af0802a4cb04162962038deabc1bd309c7 (patch)
treedd66858d5c9198cfdd5c2e7d2d824fd7787c425c /dev-lang
parentdev-perl/Pod-Parser: -r bump for decollision glue for perl <5.32 (diff)
downloadgentoo-e9b817af0802a4cb04162962038deabc1bd309c7.tar.gz
gentoo-e9b817af0802a4cb04162962038deabc1bd309c7.tar.bz2
gentoo-e9b817af0802a4cb04162962038deabc1bd309c7.zip
dev-lang/perl: Remove unaligned access direction workaround
As its been indicated that this detection has been fixed upstream in perl since 5.31.5, and the workaround should no longer be needed Bug: https://bugs.gentoo.org/676062 Bug: https://bugs.gentoo.org/688432 Bug: https://github.com/Perl/perl5/issues/16828 Bug: https://github.com/Perl/perl5/issues/16680 Commit: https://github.com/perl/perl5/commit/ee9ac1cd8eb988fea70841eae211b11355711416 Commit: https://github.com/perl/perl5/commit/e8864dba80952684bf3afe83438d4eee0c3939a9 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/perl-5.32.0-r1.ebuild8
-rw-r--r--dev-lang/perl/perl-5.32.0.ebuild8
2 files changed, 0 insertions, 16 deletions
diff --git a/dev-lang/perl/perl-5.32.0-r1.ebuild b/dev-lang/perl/perl-5.32.0-r1.ebuild
index 755c45efe8e8..c4700dfc9a7d 100644
--- a/dev-lang/perl/perl-5.32.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.32.0-r1.ebuild
@@ -620,14 +620,6 @@ src_configure() {
[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
append-cflags -Dinline=__inline__
- # fix unaligned access misdetection
- # https://rt.perl.org/Public/Bug/Display.html?id=133495
- # https://rt.perl.org/Public/Bug/Display.html?id=133803
- # bug #676062, bug #688432
- use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] || \
- [[ ${CHOST} == armv5tel* ]] \
- && myconf "-Dd_u32align='define'"
-
# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
# Prefix itself we don't do multilib either, so make sure perl can find
# something compatible.
diff --git a/dev-lang/perl/perl-5.32.0.ebuild b/dev-lang/perl/perl-5.32.0.ebuild
index 24bc98ec06ef..d5ab04c97359 100644
--- a/dev-lang/perl/perl-5.32.0.ebuild
+++ b/dev-lang/perl/perl-5.32.0.ebuild
@@ -462,14 +462,6 @@ src_configure() {
[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
append-cflags -Dinline=__inline__
- # fix unaligned access misdetection
- # https://rt.perl.org/Public/Bug/Display.html?id=133495
- # https://rt.perl.org/Public/Bug/Display.html?id=133803
- # bug #676062, bug #688432
- use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] || \
- [[ ${CHOST} == armv5tel* ]] \
- && myconf "-Dd_u32align='define'"
-
# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
# Prefix itself we don't do multilib either, so make sure perl can find
# something compatible.