summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-12-12 10:37:46 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-12-12 10:37:46 +0100
commite9ce1d49e66bcdbc3265dbc7f1e2b6fe05c2730f (patch)
treeb1c8ecc5045c3979af7d186816ecbcc26a8f5f27 /dev-lang
parentdev-java/gradle-bin: stabilize 6.8.3 for amd64, x86 (diff)
downloadgentoo-e9ce1d49e66bcdbc3265dbc7f1e2b6fe05c2730f.tar.gz
gentoo-e9ce1d49e66bcdbc3265dbc7f1e2b6fe05c2730f.tar.bz2
gentoo-e9ce1d49e66bcdbc3265dbc7f1e2b6fe05c2730f.zip
dev-lang/tk: some tests do no work
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tk/files/tk-8.6.12-test.patch31
-rw-r--r--dev-lang/tk/tk-8.6.12.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/tk/files/tk-8.6.12-test.patch b/dev-lang/tk/files/tk-8.6.12-test.patch
new file mode 100644
index 000000000000..231265f464e4
--- /dev/null
+++ b/dev-lang/tk/files/tk-8.6.12-test.patch
@@ -0,0 +1,31 @@
+--- a/tests/font.test 2020-12-26 19:15:55.199228774 +0100
++++ b/tests/font.test 2020-12-26 19:18:05.414951407 +0100
+@@ -399,7 +399,7 @@
+ # (tkfont == NULL)
+ font measure "\{xyz" abc
+ } -returnCodes error -result "font \"{xyz\" doesn't exist"
+-test font-9.5 {font command: measure} -body {
++test font-9.5 {font command: measure} -constraints knownBug -body {
+ # Tk_TextWidth()
+ expr {[font measure $fixed "abcdefg"] == [font measure $fixed "a"]*7 }
+ } -result 1
+@@ -450,7 +450,7 @@
+ # (Tcl_GetIndexFromObj() != TCL_OK)
+ font metrics $fixed -xyz
+ } -returnCodes error -result {bad metric "-xyz": must be -ascent, -descent, -linespace, or -fixed}
+-test font-10.9 {font command: metrics: get individual metrics} -body {
++test font-10.9 {font command: metrics: get individual metrics} -constraints knownBug -body {
+ font metrics $fixed -ascent
+ font metrics $fixed -descent
+ font metrics $fixed -linespace
+--- a/tests/scrollbar.test 2021-12-12 10:20:06.460611347 +0100
++++ b/tests/scrollbar.test 2021-12-12 10:21:12.204503285 +0100
+@@ -717,7 +717,7 @@
+ destroy .t .s
+ } -result {5.0}
+
+-test scrollbar-10.2.1 {<MouseWheel> event on scrollbar} -constraints {notAqua} -setup {
++test scrollbar-10.2.1 {<MouseWheel> event on scrollbar} -constraints knownBug -setup {
+ destroy .t .s
+ } -body {
+ pack [text .t -xscrollcommand {.s set} -wrap none] -side top
diff --git a/dev-lang/tk/tk-8.6.12.ebuild b/dev-lang/tk/tk-8.6.12.ebuild
index bbf26ad4fba4..1a56e674c79b 100644
--- a/dev-lang/tk/tk-8.6.12.ebuild
+++ b/dev-lang/tk/tk-8.6.12.ebuild
@@ -39,6 +39,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-8.6.10-multilib.patch
"${FILESDIR}"/${PN}-8.4.15-aqua.patch
"${FILESDIR}"/${PN}-8.6.9-conf.patch # Bug 125971
+ "${FILESDIR}"/${PN}-8.6.12-test.patch
)
src_prepare() {