summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather Cynede <cynede@gentoo.org>2015-08-16 11:59:19 +0400
committerHeather Cynede <cynede@gentoo.org>2015-08-16 11:59:19 +0400
commitfbf3297913183d19c8d1105d6408590d3bf54ded (patch)
tree7cab805a7c2cf0ad7a83a13fbf8361b3940c2c01 /dev-lang
parentsys-apps/gentoo-functions: Stable for PPC64 (bug #556154). (diff)
downloadgentoo-fbf3297913183d19c8d1105d6408590d3bf54ded.tar.gz
gentoo-fbf3297913183d19c8d1105d6408590d3bf54ded.tar.bz2
gentoo-fbf3297913183d19c8d1105d6408590d3bf54ded.zip
dev-lang/mono repair multilib-strict : Bug 554704
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/mono-3.12.1.ebuild10
-rw-r--r--dev-lang/mono/mono-4.0.3.20.ebuild10
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-lang/mono/mono-3.12.1.ebuild b/dev-lang/mono/mono-3.12.1.ebuild
index 1952ade7f2f4..51416a4136ec 100644
--- a/dev-lang/mono/mono-3.12.1.ebuild
+++ b/dev-lang/mono/mono-3.12.1.ebuild
@@ -115,3 +115,13 @@ src_test() {
cd mcs/tests || die
emake check
}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}
diff --git a/dev-lang/mono/mono-4.0.3.20.ebuild b/dev-lang/mono/mono-4.0.3.20.ebuild
index 526b34b1b9c1..0884626d5a86 100644
--- a/dev-lang/mono/mono-4.0.3.20.ebuild
+++ b/dev-lang/mono/mono-4.0.3.20.ebuild
@@ -104,3 +104,13 @@ src_test() {
cd mcs/tests || die
emake check
}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}