summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-08 13:08:48 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-08 13:08:59 +0100
commit3c621d3e668c28aff11bead9c63b5e8bdc28bae2 (patch)
treeb5bdaea7c9b427b171cba45bf092908c6bd5db55 /dev-libs/DirectFB
parentwww-client/firefox: Stable for PPC64 (bug #564818). (diff)
downloadgentoo-3c621d3e668c28aff11bead9c63b5e8bdc28bae2.tar.gz
gentoo-3c621d3e668c28aff11bead9c63b5e8bdc28bae2.tar.bz2
gentoo-3c621d3e668c28aff11bead9c63b5e8bdc28bae2.zip
dev-libs/DirectFB: Drop versions relying on libsvg (#537918)
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild151
-rw-r--r--dev-libs/DirectFB/DirectFB-1.7.1.ebuild201
-rw-r--r--dev-libs/DirectFB/DirectFB-1.7.5.ebuild201
-rw-r--r--dev-libs/DirectFB/Manifest3
4 files changed, 0 insertions, 556 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild b/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild
deleted file mode 100644
index 59a5e29edd35..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.6.3-r1.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils toolchain-funcs
-
-# Map Gentoo IUSE expand vars to DirectFB drivers
-# echo `sed -n '/Possible gfxdrivers are:/,/^$/{/Possible/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_intel="i810,i830"
-I_TO_D_mga="matrox"
-I_TO_D_r128="ati128"
-I_TO_D_s3="unichrome"
-I_TO_D_sis="sis315"
-I_TO_D_via="cle266"
-# cyber5k davinci ep9x omap pxa3xx sh772x savage pvr2d
-IUSE_VIDEO_CARDS=" intel mach64 mga neomagic nsc nvidia r128 radeon s3 sis tdfx via vmware"
-IUV=${IUSE_VIDEO_CARDS// / video_cards_}
-# echo `sed -n '/Possible inputdrivers are:/,/^$/{/\(Possible\|^input\)/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_elo2300="elo-input"
-I_TO_D_evdev="linuxinput"
-I_TO_D_mouse="ps2mouse,serialmouse"
-# dbox2remote dreamboxremote gunze h3600_ts penmount sonypijogdial ucb1x00 wm97xx zytronic
-IUSE_INPUT_DEVICES=" dynapro elo2300 evdev joystick keyboard lirc mouse mutouch tslib"
-IUD=${IUSE_INPUT_DEVICES// / input_devices_}
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://directfb.org/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
- http://directfb.org/downloads/Old/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="bmp debug +dynload doc fbcon gif gles2 imlib2 input_hub jpeg jpeg2k cpu_flags_x86_mmx mng mpeg2 multicore opengl png pnm sdl cpu_flags_x86_sse static-libs svg truetype v4l vdpau X zlib ${IUV} ${IUD}"
-REQUIRED_USE="gles2? ( opengl )"
-
-# gstreamer useflag broken
-# gstreamer? ( media-libs/FusionSound media-libs/gst-plugins-base:0.10 )
-# $(use_enable gstreamer) \
-RDEPEND="
- gif? ( media-libs/giflib )
- imlib2? ( media-libs/imlib2 )
- jpeg? ( virtual/jpeg )
- jpeg2k? ( media-libs/jasper[jpeg] )
- mng? ( media-libs/libmng )
- opengl? ( media-libs/mesa[gbm,egl,gles2?] x11-libs/libdrm )
- png? ( media-libs/libpng:0 )
- sdl? ( media-libs/libsdl )
- svg? ( x11-libs/libsvg-cairo )
- truetype? ( >=media-libs/freetype-2.0.1 )
- vdpau? ( x11-proto/xproto x11-libs/libX11 x11-libs/libXext x11-libs/libvdpau )
- X? ( x11-libs/libXext x11-libs/libX11 )
- zlib? ( sys-libs/zlib ) "
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-pkgconfig.patch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-setregion.patch \
- "${FILESDIR}"/${P}-atomic-fix-compiler-error-when-building-for-thumb2.patch
-
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-driver_list() {
- local pfx=$1
- local dev devs map
- shift
- for dev in "$@" ; do
- use ${pfx}_${dev} || continue
- map="I_TO_D_${dev}"
- devs=${devs:+${devs},}${!map:-${dev}}
- done
- echo ${devs:-none}
-}
-
-src_configure() {
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- # fix --with-gfxdrivers= logic, because opengl, vdpau and gles2 are no video_cards
- local gfxdrivers="$(driver_list video_cards ${IUSE_VIDEO_CARDS})"
- use opengl && gfxdrivers="${gfxdrivers},gl"
- use vdpau && gfxdrivers="${gfxdrivers},vdpau"
- use gles2 && gfxdrivers="${gfxdrivers},gles2"
- gfxdrivers="$(echo ${gfxdrivers} | sed 's/none,//')"
-
- # fix --with-inputdrivers= logic, don't know where to put "input_hub"
- local inputdrivers="$(driver_list input_devices ${IUSE_INPUT_DEVICES})"
- use input_hub && inputdrivers="${inputdrivers},input_hub"
- inputdrivers="$(echo ${inputdrivers} | sed 's/none,//')"
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable X x11) \
- $(use_enable fbcon fbdev) \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable cpu_flags_x86_sse sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable mng) \
- $(use_enable gif) \
- $(use_enable imlib2) \
- $(use_enable pnm) \
- $(use_enable svg) \
- $(use_enable mpeg2) \
- $(use_enable bmp) \
- $(use_enable jpeg2k jpeg2000) \
- $(use_enable truetype freetype) \
- $(use_enable debug) \
- $(use_enable zlib) \
- --disable-video4linux \
- $(use_enable v4l video4linux2) \
- $(use_enable vdpau x11vdpau) \
- $(use_enable multicore) \
- $(use_enable dynload) \
- $(use_enable opengl mesa) \
- ${sdlconf} \
- --with-gfxdrivers="${gfxdrivers}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc
-}
-
-src_install() {
- default
- dodoc fb.modes
- use doc && dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might get your mouse"
- ewarn "unexpectedly set in absolute mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/DirectFB-1.7.1.ebuild b/dev-libs/DirectFB/DirectFB-1.7.1.ebuild
deleted file mode 100644
index 15012fd530fd..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.7.1.ebuild
+++ /dev/null
@@ -1,201 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils toolchain-funcs
-
-# Map Gentoo IUSE expand vars to DirectFB drivers
-# echo `sed -n '/Possible gfxdrivers are:/,/^$/{/Possible/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_intel="i810,i830"
-I_TO_D_mga="matrox"
-I_TO_D_r128="ati128"
-I_TO_D_s3="unichrome"
-I_TO_D_sis="sis315"
-I_TO_D_via="cle266"
-# cyber5k davinci ep9x omap pxa3xx sh772x savage pvr2d
-IUSE_VIDEO_CARDS=" intel mach64 mga neomagic nsc nvidia r128 radeon s3 sis tdfx via vmware"
-IUV=${IUSE_VIDEO_CARDS// / video_cards_}
-# echo `sed -n '/Possible inputdrivers are:/,/^$/{/\(Possible\|^input\)/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_elo2300="elo-input"
-I_TO_D_evdev="linuxinput"
-I_TO_D_mouse="ps2mouse,serialmouse"
-# dbox2remote dreamboxremote gunze h3600_ts penmount sonypijogdial ucb1x00 wm97xx zytronic
-IUSE_INPUT_DEVICES=" dynapro elo2300 evdev joystick keyboard lirc mouse mutouch tslib"
-IUD=${IUSE_INPUT_DEVICES// / input_devices_}
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://directfb.org/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
- http://directfb.org/downloads/Old/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="alsa bmp cddb debug divine drmkms +dynload doc egl fbcon fusiondale fusionsound gif gles2 gstreamer imlib2 input_hub jpeg jpeg2k mad cpu_flags_x86_mmx mng mpeg2 mpeg3 multicore opengl oss png pnm sawman sdl cpu_flags_x86_sse static-libs svg swfdec tiff timidity tremor truetype v4l vdpau vorbis webp X xine zlib ${IUV} ${IUD}"
-REQUIRED_USE="gles2? ( opengl )"
-
-# ffmpeg useflag broken
-# ffmpeg? ( virtual/ffmpeg )
-# $(use_enable ffmpeg) \
-RDEPEND="
- alsa? ( media-libs/alsa-lib )
- cddb? ( media-libs/libcddb )
- drmkms? ( x11-libs/libdrm[libkms] )
- gif? ( media-libs/giflib )
- gstreamer? ( media-libs/gstreamer:1.0 media-libs/gst-plugins-base:1.0 )
- imlib2? ( media-libs/imlib2 )
- jpeg? ( virtual/jpeg )
- jpeg2k? ( media-libs/jasper[jpeg] )
- mad? ( media-libs/libmad )
- mng? ( media-libs/libmng )
- mpeg3? ( media-libs/libmpeg3 )
- opengl? ( media-libs/mesa[gbm,egl?,gles2?] x11-libs/libdrm )
- png? ( media-libs/libpng:0 )
- sdl? ( media-libs/libsdl )
- svg? ( x11-libs/libsvg-cairo )
- swfdec? ( media-libs/swfdec )
- tiff? ( media-libs/tiff:0 )
- timidity? (
- media-libs/libtimidity
- media-sound/timidity++
- )
- tremor? ( media-libs/tremor )
- truetype? ( >=media-libs/freetype-2.0.1 )
- vdpau? ( x11-proto/xproto x11-libs/libX11 x11-libs/libXext x11-libs/libvdpau )
- vorbis? ( media-libs/libvorbis )
- webp? ( media-libs/libwebp )
- X? ( x11-libs/libXext x11-libs/libX11 )
- xine? ( media-libs/xine-lib[vdpau?] )
- zlib? ( sys-libs/zlib ) "
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${PN}-1.6.3-pkgconfig.patch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${PN}-1.6.3-setregion.patch \
- "${FILESDIR}"/${PN}-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch
- sed -i \
- -e '/#define RASPBERRY_PI/d' \
- systems/egl/egl_system.c || die #497124
-
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-driver_list() {
- local pfx=$1
- local dev devs map
- shift
- for dev in "$@" ; do
- use ${pfx}_${dev} || continue
- map="I_TO_D_${dev}"
- devs=${devs:+${devs},}${!map:-${dev}}
- done
- echo ${devs:-none}
-}
-
-src_configure() {
- local myaudio="wave"
- use alsa && myaudio+=",alsa"
- use oss && myaudio+=",oss"
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- # fix --with-gfxdrivers= logic, because opengl, vdpau and gles2 are no video_cards
- local gfxdrivers="$(driver_list video_cards ${IUSE_VIDEO_CARDS})"
- use opengl && gfxdrivers="${gfxdrivers},gl"
- use vdpau && gfxdrivers="${gfxdrivers},vdpau"
- use gles2 && gfxdrivers="${gfxdrivers},gles2"
- gfxdrivers="$(echo ${gfxdrivers} | sed 's/none,//')"
-
- # fix --with-inputdrivers= logic, don't know where to put "input_hub"
- local inputdrivers="$(driver_list input_devices ${IUSE_INPUT_DEVICES})"
- use input_hub && inputdrivers="${inputdrivers},input_hub"
- inputdrivers="$(echo ${inputdrivers} | sed 's/none,//')"
-
- # The xine-vdpau flag requires a custom patch to xine-lib which we don't carry:
- # http://git.directfb.org/?p=extras/DirectFB-extra.git;a=blob;f=interfaces/IDirectFBVideoProvider/xine-lib-1.2-vdpau-hooks.patch;hb=HEAD
- econf \
- $(use_enable static-libs static) \
- $(use_enable X x11) \
- $(use_enable divine) \
- $(use_enable sawman) \
- $(use_enable fusiondale) \
- $(use_enable fusionsound) \
- $(use_enable fbcon fbdev) \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable cpu_flags_x86_sse sse) \
- $(use_enable egl) \
- $(use_enable egl idirectfbgl-egl) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable mng) \
- $(use_enable gstreamer) \
- $(use_enable gif) \
- $(use_enable tiff) \
- $(use_enable imlib2) \
- $(use_enable pnm) \
- $(use_enable svg) \
- $(use_enable mpeg2) \
- $(use_enable mpeg3 libmpeg3) \
- --disable-flash \
- $(use_enable xine) \
- --disable-xine-vdpau \
- --disable-ffmpeg \
- $(use_enable bmp) \
- $(use_enable jpeg2k jpeg2000) \
- --disable-openquicktime \
- --disable-avifile \
- $(use_enable truetype freetype) \
- $(use_enable webp) \
- $(use_enable debug) \
- $(use_enable zlib) \
- --disable-video4linux \
- $(use_enable v4l video4linux2) \
- $(use_enable vdpau x11vdpau) \
- $(use_enable multicore) \
- $(use_enable dynload) \
- $(use_enable opengl mesa) \
- $(use_enable drmkms) \
- --with-fs-drivers="${myaudio}" \
- $(use_with timidity) \
- --with-wave \
- $(use_with vorbis) \
- $(use_with tremor) \
- $(use_with mad) \
- $(use_with cddb cdda) \
- --with-playlist \
- ${sdlconf} \
- --with-gfxdrivers="${gfxdrivers}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc
-}
-
-src_install() {
- default
- dodoc fb.modes
- use doc && dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might get your mouse"
- ewarn "unexpectedly set in absolute mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/DirectFB-1.7.5.ebuild b/dev-libs/DirectFB/DirectFB-1.7.5.ebuild
deleted file mode 100644
index 3cb9a398ad0b..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.7.5.ebuild
+++ /dev/null
@@ -1,201 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils toolchain-funcs
-
-# Map Gentoo IUSE expand vars to DirectFB drivers
-# echo `sed -n '/Possible gfxdrivers are:/,/^$/{/Possible/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_intel="i810,i830"
-I_TO_D_mga="matrox"
-I_TO_D_r128="ati128"
-I_TO_D_s3="unichrome"
-I_TO_D_sis="sis315"
-I_TO_D_via="cle266"
-# cyber5k davinci ep9x omap pxa3xx sh772x savage pvr2d
-IUSE_VIDEO_CARDS=" intel mach64 mga neomagic nsc nvidia r128 radeon s3 sis tdfx via vmware"
-IUV=${IUSE_VIDEO_CARDS// / video_cards_}
-# echo `sed -n '/Possible inputdrivers are:/,/^$/{/\(Possible\|^input\)/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_elo2300="elo-input"
-I_TO_D_evdev="linuxinput"
-I_TO_D_mouse="ps2mouse,serialmouse"
-# dbox2remote dreamboxremote gunze h3600_ts penmount sonypijogdial ucb1x00 wm97xx zytronic
-IUSE_INPUT_DEVICES=" dynapro elo2300 evdev joystick keyboard lirc mouse mutouch tslib"
-IUD=${IUSE_INPUT_DEVICES// / input_devices_}
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://directfb.org/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
- http://directfb.org/downloads/Old/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="alsa bmp cddb debug divine drmkms +dynload doc egl fbcon fusiondale fusionsound gif gles2 gstreamer imlib2 input_hub jpeg jpeg2k mad cpu_flags_x86_mmx mng mpeg2 mpeg3 multicore opengl oss png pnm sawman sdl cpu_flags_x86_sse static-libs svg swfdec tiff timidity tremor truetype v4l vdpau vorbis webp X xine zlib ${IUV} ${IUD}"
-REQUIRED_USE="gles2? ( opengl )"
-
-# ffmpeg useflag broken
-# ffmpeg? ( virtual/ffmpeg )
-# $(use_enable ffmpeg) \
-RDEPEND="
- alsa? ( media-libs/alsa-lib )
- cddb? ( media-libs/libcddb )
- drmkms? ( x11-libs/libdrm[libkms] )
- gif? ( media-libs/giflib )
- gstreamer? ( media-libs/gstreamer:1.0 media-libs/gst-plugins-base:1.0 )
- imlib2? ( media-libs/imlib2 )
- jpeg? ( virtual/jpeg )
- jpeg2k? ( media-libs/jasper[jpeg] )
- mad? ( media-libs/libmad )
- mng? ( media-libs/libmng )
- mpeg3? ( media-libs/libmpeg3 )
- opengl? ( media-libs/mesa[gbm,egl?,gles2?] x11-libs/libdrm )
- png? ( media-libs/libpng:0 )
- sdl? ( media-libs/libsdl )
- svg? ( x11-libs/libsvg-cairo )
- swfdec? ( media-libs/swfdec )
- tiff? ( media-libs/tiff:0 )
- timidity? (
- media-libs/libtimidity
- media-sound/timidity++
- )
- tremor? ( media-libs/tremor )
- truetype? ( >=media-libs/freetype-2.0.1 )
- vdpau? ( x11-proto/xproto x11-libs/libX11 x11-libs/libXext x11-libs/libvdpau )
- vorbis? ( media-libs/libvorbis )
- webp? ( media-libs/libwebp )
- X? ( x11-libs/libXext x11-libs/libX11 )
- xine? ( media-libs/xine-lib[vdpau?] )
- zlib? ( sys-libs/zlib ) "
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.7.5-flags.patch \
- "${FILESDIR}"/${PN}-1.6.3-pkgconfig.patch \
- "${FILESDIR}"/${PN}-1.7.1-build.patch \
- "${FILESDIR}"/${PN}-1.6.3-setregion.patch \
- "${FILESDIR}"/${PN}-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch
- sed -i \
- -e '/#define RASPBERRY_PI/d' \
- systems/egl/egl_system.c || die #497124
-
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-driver_list() {
- local pfx=$1
- local dev devs map
- shift
- for dev in "$@" ; do
- use ${pfx}_${dev} || continue
- map="I_TO_D_${dev}"
- devs=${devs:+${devs},}${!map:-${dev}}
- done
- echo ${devs:-none}
-}
-
-src_configure() {
- local myaudio="wave"
- use alsa && myaudio+=",alsa"
- use oss && myaudio+=",oss"
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- # fix --with-gfxdrivers= logic, because opengl, vdpau and gles2 are no video_cards
- local gfxdrivers="$(driver_list video_cards ${IUSE_VIDEO_CARDS})"
- use opengl && gfxdrivers="${gfxdrivers},gl"
- use vdpau && gfxdrivers="${gfxdrivers},vdpau"
- use gles2 && gfxdrivers="${gfxdrivers},gles2"
- gfxdrivers="$(echo ${gfxdrivers} | sed 's/none,//')"
-
- # fix --with-inputdrivers= logic, don't know where to put "input_hub"
- local inputdrivers="$(driver_list input_devices ${IUSE_INPUT_DEVICES})"
- use input_hub && inputdrivers="${inputdrivers},input_hub"
- inputdrivers="$(echo ${inputdrivers} | sed 's/none,//')"
-
- # The xine-vdpau flag requires a custom patch to xine-lib which we don't carry:
- # http://git.directfb.org/?p=extras/DirectFB-extra.git;a=blob;f=interfaces/IDirectFBVideoProvider/xine-lib-1.2-vdpau-hooks.patch;hb=HEAD
- econf \
- $(use_enable static-libs static) \
- $(use_enable X x11) \
- $(use_enable divine) \
- $(use_enable sawman) \
- $(use_enable fusiondale) \
- $(use_enable fusionsound) \
- $(use_enable fbcon fbdev) \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable cpu_flags_x86_sse sse) \
- $(use_enable egl) \
- $(use_enable egl idirectfbgl-egl) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable mng) \
- $(use_enable gstreamer) \
- $(use_enable gif) \
- $(use_enable tiff) \
- $(use_enable imlib2) \
- $(use_enable pnm) \
- $(use_enable svg) \
- $(use_enable mpeg2) \
- $(use_enable mpeg3 libmpeg3) \
- --disable-flash \
- $(use_enable xine) \
- --disable-xine-vdpau \
- --disable-ffmpeg \
- $(use_enable bmp) \
- $(use_enable jpeg2k jpeg2000) \
- --disable-openquicktime \
- --disable-avifile \
- $(use_enable truetype freetype) \
- $(use_enable webp) \
- $(use_enable debug) \
- $(use_enable zlib) \
- --disable-video4linux \
- $(use_enable v4l video4linux2) \
- $(use_enable vdpau x11vdpau) \
- $(use_enable multicore) \
- $(use_enable dynload) \
- $(use_enable opengl mesa) \
- $(use_enable drmkms) \
- --with-fs-drivers="${myaudio}" \
- $(use_with timidity) \
- --with-wave \
- $(use_with vorbis) \
- $(use_with tremor) \
- $(use_with mad) \
- $(use_with cddb cdda) \
- --with-playlist \
- ${sdlconf} \
- --with-gfxdrivers="${gfxdrivers}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc
-}
-
-src_install() {
- default
- dodoc fb.modes
- use doc && dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might get your mouse"
- ewarn "unexpectedly set in absolute mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/Manifest b/dev-libs/DirectFB/Manifest
index 18dfc4e9b722..c41e1086481c 100644
--- a/dev-libs/DirectFB/Manifest
+++ b/dev-libs/DirectFB/Manifest
@@ -1,5 +1,2 @@
DIST DirectFB-1.4.9.tar.gz 3095137 SHA256 988a40dbc81fe1ecaf69a3581ed49bf4f6bbb584cb54de24cba154d3ada7a228 SHA512 ec7e03f9f3bfffafd0d84676b79845fabe59d61ac278adf4e3cd03562638529a24ff76bd606c881926cae335da00f71541e2245d0aecd4af957b95ea66c7d969 WHIRLPOOL 310c079e0f396828ddfdec0695e26a04fbea2a8a9fd90066212cf70e94a371c8b0f8b29141374db788ac247a92d01e19b0d1ddc36c78beefb6cef5aeefd173e1
-DIST DirectFB-1.6.3.tar.gz 4296908 SHA256 7a96aced0f69b2ec0810e9923068e61c21e6b19dd593e09394c872414df75e70 SHA512 86fb98951a4dc579b0d60e96976e6d85bf99e35f2fbd0d5f7cdc3d7c9ea0242052ff8dbb46bfb093e70439158cda37000e67d2a05265d3a6d2e7ac7231c2ebb7 WHIRLPOOL ce9d1f3a1e7e9aaed3572244390c0dec87faa5e8af1a58153ad849774e08be0037f42983852de323cab745dc6b3d018640ec2d5987270b6a4b5ab7595bbd97aa
-DIST DirectFB-1.7.1.tar.gz 5875460 SHA256 dd7de38b3cd1408411b37ca28ec73e14b7672e5e28256b7bf91826240c81f519 SHA512 caf24c04b8155b9b9dbea321c627925f60809aa7edd1ab4f9fcf28a40e14accdb2a4226f5de7a26ab5928b7df7fd85c616a966d036800ba2a675724314065982 WHIRLPOOL 9d1448b48e8fec0dac633e5afd6eb92d48edfa3874998d88d50a7dec99c89a20d738cfbcf0aef8cff346cffc0901bf5e675c6df92bbf97a35880add34877b90d
-DIST DirectFB-1.7.5.tar.gz 5996591 SHA256 7b76d4a48aa71cce4d5e1878afc548cc48f21d55751d8d5aa4c4cdfcbb40ed03 SHA512 d447f2c3892d90902773ae58e0f0cc87b384070f6f5d63a2412138d7c4a53288b688092fa681e6489dcbf36b2bd48c3e3aab162da52680499841b07b5a6daa4f WHIRLPOOL 123e1ab63e556fa50c9a4b288a773f55d3ab46fe4ed5d32b2198f140fde9afaa98167112a3bfbb9e0496349463e37ea36a32200f278b7bdc1cfb1b9dfbabafb8
DIST DirectFB-1.7.6.tar.gz 5975444 SHA256 44f32bacfb842ea234599532f8481fe41b5bd2310d2bd101508eb3a5df26c9e1 SHA512 18cf1aad6c277a6de147a9b0aff1cd7408ddd7c7159ef21dab9a548db7399c681603624e7820b186a29e03edaa7737350a61e2abaec572887e9cc56658bf85a2 WHIRLPOOL 2868906bbd2b4e681c6702f164f7ba4f01a0f538aea0c744c6e77ce32b274a967232ef0046ec21b74c9c53c4824182e632159cca5ea0c7c27292cb258257d6a8