summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-07-15 20:55:05 -0400
committerAaron Bauman <bman@gentoo.org>2017-07-15 20:55:05 -0400
commit7a05ee92d9ad72ca9594758747af4dfc1305adfb (patch)
tree9b1f0c9856030092d52fb203d10f15ccbe4e74e9 /dev-libs/DirectFB
parentapp-arch/dump: remove old wrt sec bug #515274 (diff)
downloadgentoo-7a05ee92d9ad72ca9594758747af4dfc1305adfb.tar.gz
gentoo-7a05ee92d9ad72ca9594758747af4dfc1305adfb.tar.bz2
gentoo-7a05ee92d9ad72ca9594758747af4dfc1305adfb.zip
dev-libs/DirectFB: drop vulnerable wrt sec bug #510472
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild122
-rw-r--r--dev-libs/DirectFB/Manifest1
2 files changed, 0 insertions, 123 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild b/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild
deleted file mode 100644
index f949a57664ac..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-inherit eutils toolchain-funcs
-
-# Map Gentoo IUSE expand vars to DirectFB drivers
-# echo `sed -n '/Possible gfxdrivers are:/,/^$/{/Possible/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_intel="i810,i830"
-I_TO_D_mga="matrox"
-I_TO_D_r128="ati128"
-I_TO_D_s3="unichrome"
-I_TO_D_sis="sis315"
-I_TO_D_via="cle266"
-# cyber5k davinci ep9x gl omap pxa3xx sh772x
-IUSE_VIDEO_CARDS=" intel mach64 mga neomagic nsc nvidia r128 radeon s3 savage sis tdfx via vmware"
-IUV=${IUSE_VIDEO_CARDS// / video_cards_}
-# echo `sed -n '/Possible inputdrivers are:/,/^$/{/\(Possible\|^input\)/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
-I_TO_D_elo2300="elo-input"
-I_TO_D_evdev="linuxinput"
-I_TO_D_mouse="ps2mouse serialmouse"
-# dbox2remote dreamboxremote gunze h3600_ts penmount sonypijogdial ucb1x00 wm97xx zytronic
-IUSE_INPUT_DEVICES=" dynapro elo2300 evdev joystick keyboard lirc mouse mutouch tslib"
-IUD=${IUSE_INPUT_DEVICES// / input_devices_}
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.net/"
-SRC_URI="http://directfb.net/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
- http://directfb.net/downloads/Old/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 -mips ppc ppc64 sh -sparc x86"
-IUSE="debug doc fbcon gif jpeg cpu_flags_x86_mmx png sdl cpu_flags_x86_sse static-libs truetype v4l X zlib ${IUV} ${IUD}"
-
-RDEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( virtual/jpeg )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )
- X? ( x11-libs/libXext x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.2.7-CFLAGS.patch \
- "${FILESDIR}"/${PN}-1.2.0-headers.patch \
- "${FILESDIR}"/${PN}-1.1.1-pkgconfig.patch \
- "${FILESDIR}"/${PN}-1.4.9-libpng-1.5.patch
-
- # the media subdir uses sqrt(), so make sure it links in -lm
- sed -i \
- -e '/libdirectfb_media_la_LIBADD/s:$: -lm:' \
- src/media/Makefile.in || die
-
- # Avoid invoking `ld` directly #300779
- find . -name Makefile.in -exec sed -i \
- '/[$](LD)/s:$(LD) -o $@ -r:$(CC) $(LDFLAGS) $(CFLAGS) -Wl,-r -nostdlib -o $@:' {} +
-}
-
-driver_list() {
- local pfx=$1
- local dev devs map
- shift
- for dev in "$@" ; do
- use ${pfx}_${dev} || continue
- map="I_TO_D_${dev}"
- devs=${devs:+${devs},}${!map:-${dev}}
- done
- echo ${devs:-none}
-}
-
-src_configure() {
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- econf \
- --disable-dependency-tracking \
- $(use_enable static-libs static) \
- $(use_enable X x11) \
- $(use_enable fbcon fbdev) \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable cpu_flags_x86_sse sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable debug) \
- $(use_enable zlib) \
- --disable-video4linux \
- $(use_enable v4l video4linux2) \
- ${sdlconf} \
- --with-gfxdrivers="$(driver_list video_cards ${IUSE_VIDEO_CARDS})" \
- --with-inputdrivers="$(driver_list input_devices ${IUSE_INPUT_DEVICES})" \
- --disable-vnc
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- use doc && dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might get your mouse"
- ewarn "unexpectedly set in absolute mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/Manifest b/dev-libs/DirectFB/Manifest
index c41e1086481c..165fa849f864 100644
--- a/dev-libs/DirectFB/Manifest
+++ b/dev-libs/DirectFB/Manifest
@@ -1,2 +1 @@
-DIST DirectFB-1.4.9.tar.gz 3095137 SHA256 988a40dbc81fe1ecaf69a3581ed49bf4f6bbb584cb54de24cba154d3ada7a228 SHA512 ec7e03f9f3bfffafd0d84676b79845fabe59d61ac278adf4e3cd03562638529a24ff76bd606c881926cae335da00f71541e2245d0aecd4af957b95ea66c7d969 WHIRLPOOL 310c079e0f396828ddfdec0695e26a04fbea2a8a9fd90066212cf70e94a371c8b0f8b29141374db788ac247a92d01e19b0d1ddc36c78beefb6cef5aeefd173e1
DIST DirectFB-1.7.6.tar.gz 5975444 SHA256 44f32bacfb842ea234599532f8481fe41b5bd2310d2bd101508eb3a5df26c9e1 SHA512 18cf1aad6c277a6de147a9b0aff1cd7408ddd7c7159ef21dab9a548db7399c681603624e7820b186a29e03edaa7737350a61e2abaec572887e9cc56658bf85a2 WHIRLPOOL 2868906bbd2b4e681c6702f164f7ba4f01a0f538aea0c744c6e77ce32b274a967232ef0046ec21b74c9c53c4824182e632159cca5ea0c7c27292cb258257d6a8