summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/Manifest3
-rw-r--r--dev-libs/ace/ace-5.7.2.ebuild85
-rw-r--r--dev-libs/ace/files/ace-missing-refcountable-header.patch26
-rw-r--r--dev-libs/ace/metadata.xml11
4 files changed, 125 insertions, 0 deletions
diff --git a/dev-libs/ace/Manifest b/dev-libs/ace/Manifest
new file mode 100644
index 000000000000..4ff8308da3af
--- /dev/null
+++ b/dev-libs/ace/Manifest
@@ -0,0 +1,3 @@
+DIST ACE+TAO+CIAO-5.7.2.tar.bz2 49824451 SHA256 5290e378c9417892e7e57eef06e74affeb6a93ba3e7c67e24e02e72c282ea37a SHA512 798707aaa04b253f4b1241cd3263a87bdf7188437f858aac910a6fbf54bcf27c41f827fe81cea68b813ac068bd7a04f63e7f4eb948432d9240c4979fdf7f0ce1 WHIRLPOOL 23214425fd1d2a13622b1f21ec16fde84eb76a22305a6393642cdb4ea3d6d58481b59323a64ac91bed7ff672d5b5e8b6fe389ed9620ce898a00bf6332370d38e
+DIST ACE+TAO-5.7.2.tar.bz2 26111373 SHA256 95d9bfe506bfe55e489863413d83f214d2f6948a836449ed4dce6cf8c7d05d1d SHA512 9c25bc3773dd92d943bf67595470a485be1d7ebe893ddf20ec55a77d66080cf755e0c5cdc77a8f53d49d1f2ae4ec03cdbc7ac0dc68e179467b8ce7ad3abb5387 WHIRLPOOL 02b575fc831e988164be3667f1c8b34ef7bd6c5fe131884d4443058a70ca68f975391e5b7efc56235e4d4b598879941fd6737a7a1d0448b837a512ee7269630e
+DIST ACE-5.7.2.tar.bz2 9724175 SHA256 e358281a93cbc932351030675fb7956875f996e0dc42cf1f499a2d5bd018e0ad SHA512 7f5d77ea9ab1f03ad615cf6b01cb75b0484c5e828790609b8492463153a34c62d974000c0f3952dfdab143cad3c0aa6e2ddc7ea089989b6e9b9797bc6430d38b WHIRLPOOL e57db857a3ca1411fe3bcf166b7aee059d8e07e752cdd919e9ca7a1766bea7562027752326a24937719da432323569f302360849d3976bd44f05f0bfb1ce0946
diff --git a/dev-libs/ace/ace-5.7.2.ebuild b/dev-libs/ace/ace-5.7.2.ebuild
new file mode 100644
index 000000000000..f12c69967b79
--- /dev/null
+++ b/dev-libs/ace/ace-5.7.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="The Adaptive Communications Environment"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
+ tao? (
+ !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
+ ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
+ )"
+
+LICENSE="ACE BSD BSD-4 BSD-2 tao? ( sun-iiop RSA )"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="X ipv6 tao ciao"
+
+COMMON_DEPEND="dev-libs/openssl"
+# TODO probably more
+RDEPEND="${COMMON_DEPEND}
+ X? ( x11-libs/libXt x11-libs/libXaw )"
+
+DEPEND="${COMMON_DEPEND}
+ X? ( x11-proto/xproto )"
+
+S="${WORKDIR}/ACE_wrappers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Let's avoid autotools. http://bugs.gentoo.org/328027.
+ if has_version ">=dev-libs/openssl-1.0.0"; then
+ sed -i -e 's:SSL_METHOD:const SSL_METHOD:' configure || die
+ fi
+
+ sed -i -e 's/-O3//' configure || die
+}
+
+src_compile() {
+ export ACE_ROOT="${S}"
+ mkdir build
+ cd build
+
+ ECONF_SOURCE="${S}"
+ econf \
+ --enable-lib-all \
+ $(use_with X) \
+ $(use_enable ipv6) \
+ || die "econf died"
+ # --with-qos needs ACE_HAS_RAPI
+ emake static_libs=1 || die "emake failed"
+}
+
+src_install() {
+ cd build
+ emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+ # punt gperf stuff
+ rm -rf "${D}/usr/bin" "${D}/usr/share"
+ # remove PACKAGE_* definitions from installed config.h (#192676)
+ sed -i -e "s:^[ \t]*#define[ \t]\+PACKAGE_.*$:/\* & \*/:g" "${D}/usr/include/ace/config.h"
+
+ # Install some docs
+ cd "${S}"
+ dodoc README NEWS ChangeLog AUTHORS VERSION Release || die
+}
+
+src_test() {
+ cd "${S}/build"
+ emake ACE_ROOT="${S}" check || die "self test failed"
+}
+
+pkg_postinst() {
+
+ local CC_MACHINE=$($(tc-getCC) -dumpmachine)
+ if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
+ ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
+ ewarn "ace.old"
+ ewarn "This is required, as anything trying to compile against ACE will"
+ ewarn "have problems with conflicting OS.h files if this is not done."
+ mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
+ "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/ace-missing-refcountable-header.patch b/dev-libs/ace/files/ace-missing-refcountable-header.patch
new file mode 100644
index 000000000000..df5c4070ea8e
--- /dev/null
+++ b/dev-libs/ace/files/ace-missing-refcountable-header.patch
@@ -0,0 +1,26 @@
+--- ace/Makefile.am.orig 2008-10-22 22:28:29.000000000 +0300
++++ ace/Makefile.am 2008-10-22 22:29:50.000000000 +0300
+@@ -876,6 +876,7 @@
+ Recursive_Thread_Mutex.inl \
+ Recyclable.h \
+ Recyclable.inl \
++ Refcountable.h \
+ Refcountable_T.cpp \
+ Refcountable_T.h \
+ Refcountable_T.inl \
+@@ -1054,6 +1055,7 @@
+ Timeprobe_T.h \
+ Timer_Hash_T.cpp \
+ Timer_Hash_T.h \
++ Timer_Heap.h \
+ Timer_Heap_T.cpp \
+ Timer_Heap_T.h \
+ Timer_List_T.cpp \
+@@ -1061,6 +1063,7 @@
+ Timer_Queue_Adapters.cpp \
+ Timer_Queue_Adapters.h \
+ Timer_Queue_Adapters.inl \
++ Timer_Queue.h \
+ Timer_Queue_T.cpp \
+ Timer_Queue_T.h \
+ Timer_Queue_T.inl \
diff --git a/dev-libs/ace/metadata.xml b/dev-libs/ace/metadata.xml
new file mode 100644
index 000000000000..1444c9845d97
--- /dev/null
+++ b/dev-libs/ace/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cpp</herd>
+<use>
+ <flag name='ciao'>Include Component Intergraced Ace ORB into the build of
+ ace</flag>
+ <flag name='tao'>Include the ACE ORB (CORBA stuff) (called tao) into the
+ build of ace</flag>
+</use>
+</pkgmetadata>