summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-03 15:02:59 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-03 21:12:23 -0400
commit012abdf59420fda11e19ceba0582fda2fc3fbd70 (patch)
treec4985d7ea8d629c5a7ce4218f04112c8620e6948 /dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
parentdev-lang/snobol: drop old EAPI (diff)
downloadgentoo-012abdf59420fda11e19ceba0582fda2fc3fbd70.tar.gz
gentoo-012abdf59420fda11e19ceba0582fda2fc3fbd70.tar.bz2
gentoo-012abdf59420fda11e19ceba0582fda2fc3fbd70.zip
dev-libs/boehm-gc: drop old EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
deleted file mode 100644
index cf5927c9f57d..000000000000
--- a/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-MY_P="gc-${PV/_/}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
-HOMEPAGE="http://www.hboehm.info/gc/"
-SRC_URI="http://www.hboehm.info/gc/gc_source/${MY_P}.tar.gz"
-
-LICENSE="boehm-gc"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86"
-IUSE="cxx threads"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e '/^SUBDIRS/s/doc//' Makefile.in || die
- epatch "${FILESDIR}"/${PN}-6.5-gentoo.patch
- epatch "${FILESDIR}"/gc6.6-builtin-backtrace-uclibc.patch
- sed '/Cflags/s:$:/gc:g' -i bdw-gc.pc.in || die
-}
-
-src_compile() {
- econf \
- $(use_enable cxx cplusplus) \
- $(use threads || echo --disable-threads)
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- rm -rf "${D}"/usr/share/gc || die
-
- # dist_noinst_HEADERS
- insinto /usr/include/gc
- doins include/{cord.h,ec.h,javaxfc.h}
- insinto /usr/include/gc/private
- doins include/private/*.h
-
- dodoc README.QUICK doc/README* doc/barrett_diagram
- dohtml doc/*.html
- newman doc/gc.man GC_malloc.1
-}