summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-05 14:41:42 +0000
committerSam James <sam@gentoo.org>2020-11-05 14:41:48 +0000
commit6236db536ac8d5acfa157119c469cc06dfec7b8d (patch)
treecce4638968ee2fd1eb7f630f04c6ff3a0e079d1b /dev-libs/botan
parentprofiles/package.mask: start last rites for dev-db/couchdb-python (diff)
downloadgentoo-6236db536ac8d5acfa157119c469cc06dfec7b8d.tar.gz
gentoo-6236db536ac8d5acfa157119c469cc06dfec7b8d.tar.bz2
gentoo-6236db536ac8d5acfa157119c469cc06dfec7b8d.zip
dev-libs/botan: bump to 2.17.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-2.17.0.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index b54bb404607e..f7db92923eb5 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,2 +1,3 @@
DIST Botan-2.15.0.tar.xz 5920688 BLAKE2B 1bbb9cadb0f754194851bddf8b14dbcd291285c5f3fbaad35920277a11c3d9e1b1e5cc484c0d37b1c7999b3084a1c90da56631df0b07e788372b95aff5197031 SHA512 0965a0a6141df44e38bd7da038b89dd2b3808ed9a4ebaafbf089abf60718e62cba78d7b64eaf272b5df8c5a489222e4cad4fb511cde38e76cdaed87f35896c18
DIST Botan-2.16.0.tar.xz 5938644 BLAKE2B a4b7bb48aee0dbf0f8b81a407b6a39707c3e6040a2bb93f9c34208ab87ea64879b2e56af66f090a73d66b64156e333c89e490d206e666e665a5eb4fbcd98d13e SHA512 12550425c695119d7f448a47b7956565de373e1bc86b8fdfa0a2a5b9fed1ef93a36101b6480e7a2f78e9262c988904c353fa021b681543691d09bf5b00495bd4
+DIST Botan-2.17.0.tar.xz 5972376 BLAKE2B 2e1bfcf1f118f16f1fa5647e45da35649305a2f790254321a2b2a6ebb40c38a559c2c64de4f85536610e65fc2d880f4324eed7d6a047b35cdb447fc80d4fa280 SHA512 fe5e3abcd10cf3e9b6f74248d9934722f41c5618a5f034e811ac9bc28d3162ae8259c5f90b61e1e85bf63957360d1ed0f001239eab81455d8b7b7f89d4c2940c
diff --git a/dev-libs/botan/botan-2.17.0.ebuild b/dev-libs/botan/botan-2.17.0.ebuild
new file mode 100644
index 000000000000..17cef74104b9
--- /dev/null
+++ b/dev-libs/botan/botan-2.17.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit python-r1 toolchain-funcs
+
+MY_P="Botan-${PV}"
+
+DESCRIPTION="C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="2/$(ver_cut 1-2)" # soname version
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="bindist bzip2 boost doc libressl lzma python sqlite ssl static-libs zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')
+"
+
+# NOTE: Boost is needed at runtime too for the CLI tool.
+DEPEND="
+ boost? ( >=dev-libs/boost-1.48:= )
+ bzip2? ( >=app-arch/bzip2-1.0.5:= )
+ lzma? ( app-arch/xz-utils:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ sqlite? ( dev-db/sqlite:3= )
+ zlib? ( >=sys-libs/zlib-1.2.3:= )
+"
+
+RDEPEND="${DEPEND}"
+
+# NOTE: Considering patching Botan?
+# Please see upstream's guidance:
+# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches
+
+python_check_deps() {
+ if use doc ; then
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ local disable_modules=()
+ use boost || disable_modules+=( "boost" )
+ use bindist && disable_modules+=( "ecdsa" )
+ elog "Disabling module(s): ${disable_modules[@]}"
+
+ # Enable v9 instructions for sparc64
+ local chostarch="${CHOST%%-*}"
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]] ; then
+ chostarch="sparc32-v9"
+ fi
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ case ${CHOST} in
+ hppa*) chostarch=parisc ;;
+ esac
+
+ local pythonvers=()
+ if use python ; then
+ _append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+
+ python_foreach_impl _append
+ fi
+
+ # Don't install Python bindings automatically
+ # (do it manually later in the right place)
+ # https://bugs.gentoo.org/723096
+ local myargs=(
+ $(use_enable static-libs static-library)
+ $(use_with boost)
+ $(use_with bzip2)
+ $(use_with doc documentation)
+ $(use_with doc sphinx)
+ $(use_with lzma)
+ $(use_with sqlite sqlite3)
+ $(use_with ssl openssl)
+ $(use_with zlib)
+ $(usex hppa --without-stack-protector '')
+ --cpu=${chostarch}
+ --disable-modules=$( IFS=","; echo "${disable_modules[*]}" )
+ --docdir=share/doc
+ --libdir=$(get_libdir)
+ --os=${myos}
+ --distribution-info="Gentoo ${PVR}"
+ --prefix="${EPREFIX}/usr"
+ --with-endian="$(tc-endian)"
+ --with-python-version=$( IFS=","; echo "${pythonvers[*]}" )
+ --without-doxygen
+ --no-install-python-module
+ )
+
+ tc-export CC CXX AR
+
+ ./configure.py "${myargs[@]}" || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+
+ # Manually install the Python bindings (bug #723096)
+ if use python ; then
+ python_foreach_impl python_domodule src/python/botan2.py
+ fi
+}