summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-03-23 15:12:38 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-03-23 15:13:50 +0200
commitd3efafeaa44070379d2c8d68ae976e061d921c8b (patch)
treeabad267b7f9ed40e384e4a3c332ca6b35c853c19 /dev-libs/check
parentdev-libs/check: update subunit logic, fix pkgconfig file (diff)
downloadgentoo-d3efafeaa44070379d2c8d68ae976e061d921c8b.tar.gz
gentoo-d3efafeaa44070379d2c8d68ae976e061d921c8b.tar.bz2
gentoo-d3efafeaa44070379d2c8d68ae976e061d921c8b.zip
dev-libs/check: remove faulty 0.14.0-r1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/check')
-rw-r--r--dev-libs/check/check-0.14.0-r1.ebuild50
-rw-r--r--dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch23
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-libs/check/check-0.14.0-r1.ebuild b/dev-libs/check/check-0.14.0-r1.ebuild
deleted file mode 100644
index ff085a62e157..000000000000
--- a/dev-libs/check/check-0.14.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="A unit test framework for C"
-HOMEPAGE="https://libcheck.github.io/check/"
-SRC_URI="https://github.com/lib${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc subunit test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="subunit? ( dev-python/subunit[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-apps/texinfo"
-BDEPEND="doc? ( app-doc/doxygen )"
-
-PATCHES=( "${FILESDIR}/check-0.14.0-r1-disable-automagic-dep.patch" )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCHECK_ENABLE_TESTS=$(usex test ON OFF)
- -DCHECK_ENABLE_SUBUNIT=$(usex subunit 1 0)
- )
-
- cmake_src_configure
-}
-
-multilib_src_compile() {
- cmake_src_compile
-
- if use doc && multilib_is_native_abi; then
- cd "${S}"/doc/ || die "Failed to switch directories."
- doxygen "." || die "Failed to run doxygen to generate docs."
- fi
-}
-
-multilib_src_install_all() {
- use doc && local HTML_DOCS=( "${S}"/doc/html/. )
- einstalldocs
-
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
-}
diff --git a/dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch b/dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch
deleted file mode 100644
index a79a7bcccddb..000000000000
--- a/dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/CMakeLists.txt 2020-03-21 09:42:30.411037664 +0200
-+++ b/CMakeLists.txt 2020-03-21 09:49:12.358161439 +0200
-@@ -365,15 +365,16 @@
- ADD_DEFINITIONS(-DHAVE_LIBRT=1)
- endif (HAVE_LIBRT)
-
--check_library_exists(subunit subunit_test_start "" HAVE_SUBUNIT)
--if (HAVE_SUBUNIT)
-+option(CHECK_ENABLE_SUBUNIT "Enable subunit support" ON)
-+if (CHECK_ENABLE_SUBUNIT EQUAL 1)
- set(SUBUNIT "subunit")
- set(ENABLE_SUBUNIT 1)
-+ set(HAVE_SUBUNIT 1)
- add_definitions(-DENABLE_SUBUNIT=1)
--else(HAVE_SUBUNIT)
-+else(CHECK_ENABLE_SUBUNIT EQUAL 0)
- set(ENABLE_SUBUNIT 0)
- add_definitions(-DENABLE_SUBUNIT=0)
--endif (HAVE_SUBUNIT)
-+endif (CHECK_ENABLE_SUBUNIT)
-
- ###############################################################################
- # Generate "config.h" from "cmake/config.h.in"