summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/chmlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/chmlib')
-rw-r--r--dev-libs/chmlib/Manifest1
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r1.ebuild27
-rw-r--r--dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch20
-rw-r--r--dev-libs/chmlib/files/chmlib-0.40-headers.patch18
-rw-r--r--dev-libs/chmlib/metadata.xml8
5 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/chmlib/Manifest b/dev-libs/chmlib/Manifest
new file mode 100644
index 000000000000..f4feafc799c8
--- /dev/null
+++ b/dev-libs/chmlib/Manifest
@@ -0,0 +1 @@
+DIST chmlib-0.40.tar.bz2 252036 SHA256 3449d64b0cf71578b2c7e3ddc048d4af3661f44a83941ea074a7813f3a59ffa3 SHA512 3a3e151cf455b19e9e7c163a1d1e5ac52e8196f0b98f77932c72af58f3517824b9244667a18279ae754ccea784f6d6ab0c47465e74e3768ce98bb7dca0ca16e3 WHIRLPOOL db83f3e72e7e87d4d0502482e22fef2652f9f3b9b3878217a8f8f51201f2968badd7e5d92af7da3ecb504f0e71923cae7d84a1637039d22db138fd050762d6cf
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
new file mode 100644
index 000000000000..b4fa6a5f5309
--- /dev/null
+++ b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="Library for MS CHM (compressed html) file format"
+HOMEPAGE="http://www.jedrea.com/chmlib/"
+SRC_URI="http://www.jedrea.com/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 x86"
+IUSE="+examples static-libs"
+
+DOCS=(AUTHORS NEWS README)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.39-stdtypes.patch
+ "${FILESDIR}"/${P}-headers.patch
+)
+
+src_configure() {
+ myeconfargs=($(use_enable examples))
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch b/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch
new file mode 100644
index 000000000000..0f9232017689
--- /dev/null
+++ b/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch
@@ -0,0 +1,20 @@
+--- src/chm_lib.c
++++ src/chm_lib.c
+@@ -149,6 +149,17 @@ typedef unsigned __int32 UInt32;
+ typedef __int64 Int64;
+ typedef unsigned __int64 UInt64;
+
++/* Linux: use C standard types */
++#elif defined(__linux__)
++#include <stdint.h>
++typedef unsigned char UChar;
++typedef int16_t Int16;
++typedef uint16_t UInt16;
++typedef int32_t Int32;
++typedef uint32_t UInt32;
++typedef int64_t Int64;
++typedef uint64_t UInt64;
++
+ /* I386, 32-bit, non-Windows */
+ /* Sparc */
+ /* MIPS */
diff --git a/dev-libs/chmlib/files/chmlib-0.40-headers.patch b/dev-libs/chmlib/files/chmlib-0.40-headers.patch
new file mode 100644
index 000000000000..d60af28639fd
--- /dev/null
+++ b/dev-libs/chmlib/files/chmlib-0.40-headers.patch
@@ -0,0 +1,18 @@
+--- src/chm_http.c
++++ src/chm_http.c
+@@ -34,6 +34,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #if __sun || __sgi
+ #include <strings.h>
+ #endif
+@@ -42,6 +43,7 @@
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+
+ /* threading includes */
+ #include <pthread.h>
diff --git a/dev-libs/chmlib/metadata.xml b/dev-libs/chmlib/metadata.xml
new file mode 100644
index 000000000000..0cb5b5e2962f
--- /dev/null
+++ b/dev-libs/chmlib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+</pkgmetadata>