summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-11 11:52:56 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-11 12:08:57 +0200
commitb2a0d4f08471f8a932654e1a5993533877a06f51 (patch)
tree1d0f85c08fdc83d2026eed43285d90515136d494 /dev-libs/cl/cl-9999.ebuild
parentmedia-libs/esdl: Version bump. (diff)
downloadgentoo-b2a0d4f08471f8a932654e1a5993533877a06f51.tar.gz
gentoo-b2a0d4f08471f8a932654e1a5993533877a06f51.tar.bz2
gentoo-b2a0d4f08471f8a932654e1a5993533877a06f51.zip
dev-libs/cl: Initial commit by Brian Gortney (bug #502066).
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs/cl/cl-9999.ebuild')
-rw-r--r--dev-libs/cl/cl-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/cl/cl-9999.ebuild b/dev-libs/cl/cl-9999.ebuild
new file mode 100644
index 000000000000..eb125992a21f
--- /dev/null
+++ b/dev-libs/cl/cl-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/esdl/esdl-1.2.ebuild,v 1.1 2013/02/12 14:41:54 george Exp $
+
+EAPI=6
+inherit eutils fixheadtails git-r3 multilib
+
+DESCRIPTION="OpenCL bindings for Erlang"
+HOMEPAGE="https://github.com/tonyrog/cl"
+EGIT_REPO_URI="https://github.com/tonyrog/cl.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-lang/erlang-16
+ virtual/opencl
+ dev-util/rebar
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ rebar compile || die
+}
+
+src_install() {
+ addpredict /usr/$(get_libdir)/erlang/lib
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ CL_DIR="${ERLANG_DIR}/${P}"
+
+ insinto "${CL_DIR}"
+ doins -r ebin src include c_src examples
+}