summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/clearsilver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/clearsilver')
-rw-r--r--dev-libs/clearsilver/Manifest1
-rw-r--r--dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild76
-rw-r--r--dev-libs/clearsilver/files/clearsilver-0.10.5-libdir.patch13
-rw-r--r--dev-libs/clearsilver/files/clearsilver-0.10.5-libz.patch10
-rw-r--r--dev-libs/clearsilver/files/clearsilver-0.10.5-perl_installdir.patch22
-rw-r--r--dev-libs/clearsilver/metadata.xml5
6 files changed, 127 insertions, 0 deletions
diff --git a/dev-libs/clearsilver/Manifest b/dev-libs/clearsilver/Manifest
new file mode 100644
index 000000000000..105af55f80d2
--- /dev/null
+++ b/dev-libs/clearsilver/Manifest
@@ -0,0 +1 @@
+DIST clearsilver-0.10.5.tar.gz 439190 SHA256 1e9da038deafddd3d0c1c510626c28be5a0f4f17b9091d577fd30e7c5ba88680 SHA512 05a3c2140d462b8120fa41f74c09ca9246184259b6bdf147581e23e4441f700b9737f82145d8ff96996d93e37bd6a660c68f58f27370c903777a914235ea53b9 WHIRLPOOL a1ec3c88d46d4ab61f3540f62a5461679353102dbf4a0837b369a6a4d769c7f7a9934662575f75f2cf7b29aa7b9581d0dbcea6847548fae71f8998eb612146f2
diff --git a/dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild b/dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild
new file mode 100644
index 000000000000..aac4535f37b0
--- /dev/null
+++ b/dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Please note: apache, java, mono and ruby support disabled for now.
+# Fill a bug if you need it.
+#
+# dju@gentoo.org, 4th July 2005
+
+EAPI=5
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? 2"
+
+inherit autotools eutils multilib perl-app python
+
+DESCRIPTION="Clearsilver is a fast, powerful, and language-neutral HTML template system"
+HOMEPAGE="http://www.clearsilver.net/"
+SRC_URI="http://www.clearsilver.net/downloads/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="perl python zlib"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+DOCS=(README INSTALL)
+
+pkg_setup() {
+ if use python; then
+ DOCS+=(README.python)
+
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-perl_installdir.patch
+
+ use zlib && epatch "${FILESDIR}"/${P}-libz.patch
+
+ epatch "${FILESDIR}"/${P}-libdir.patch
+ sed -i -e "s:GENTOO_LIBDIR:$(get_libdir):" configure.in
+ eautoreconf
+
+ # Fix for Gentoo/Freebsd
+ [[ "${ARCH}" == FreeBSD ]] && touch ${S}/features.h ${S}/cgi/features.h
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl) \
+ $(use_with perl perl /usr/bin/perl) \
+ $(use_enable python) \
+ $(use_with python python /usr/bin/python) \
+ $(use_enable zlib compression) \
+ "--disable-apache" \
+ "--disable-ruby" \
+ "--disable-java" \
+ "--disable-csharp"
+}
+
+src_compile() {
+ default
+}
+
+src_install () {
+ default
+
+ if use perl ; then
+ perl_delete_localpod || die "perl_delete_localpod failed"
+ fi
+}
diff --git a/dev-libs/clearsilver/files/clearsilver-0.10.5-libdir.patch b/dev-libs/clearsilver/files/clearsilver-0.10.5-libdir.patch
new file mode 100644
index 000000000000..46f1c91279f9
--- /dev/null
+++ b/dev-libs/clearsilver/files/clearsilver-0.10.5-libdir.patch
@@ -0,0 +1,13 @@
+--- configure.in.orig 2007-02-14 13:13:10.000000000 +0100
++++ configure.in 2007-02-14 13:18:39.000000000 +0100
+@@ -253,8 +253,8 @@
+ vers=`$python_bin -c "import sys; print sys.version[[:3]]"`
+ py_inst_dir=`$python_bin -c "import sys; print sys.exec_prefix"`
+ python_inc=$py_inst_dir/include/python$vers
+- python_lib="-L$py_inst_dir/lib/python$vers/config -lpython$vers"
+- python_site=$py_inst_dir/lib/python$vers/site-packages
++ python_lib="-L$py_inst_dir/GENTOO_LIBDIR/python$vers/config -lpython$vers"
++ python_site=$py_inst_dir/GENTOO_LIBDIR/python$vers/site-packages
+ else
+ for vers in $python_versions; do
+ for path in $python_search_path; do
diff --git a/dev-libs/clearsilver/files/clearsilver-0.10.5-libz.patch b/dev-libs/clearsilver/files/clearsilver-0.10.5-libz.patch
new file mode 100644
index 000000000000..5bed42ab64d6
--- /dev/null
+++ b/dev-libs/clearsilver/files/clearsilver-0.10.5-libz.patch
@@ -0,0 +1,10 @@
+--- python/setup.py.orig 2007-10-28 21:20:00.000000000 +0200
++++ python/setup.py 2007-10-28 21:20:34.000000000 +0200
+@@ -122,6 +122,7 @@
+ include_dirs=INC_DIRS,
+ library_dirs=LIB_DIRS,
+ libraries=LIBRARIES,
++ extra_link_args = ["-lz"],
+ )]
+ }
+
diff --git a/dev-libs/clearsilver/files/clearsilver-0.10.5-perl_installdir.patch b/dev-libs/clearsilver/files/clearsilver-0.10.5-perl_installdir.patch
new file mode 100644
index 000000000000..a8073e1f0afb
--- /dev/null
+++ b/dev-libs/clearsilver/files/clearsilver-0.10.5-perl_installdir.patch
@@ -0,0 +1,22 @@
+X-Bug-Debian: http://bugs.debian.org/357908
+X-Bug-Gentoo: https://bugs.gentoo.org/295895
+--- b/Makefile
++++ a/Makefile
+@@ -29,7 +29,7 @@
+ @for mdir in $(SUBDIRS); do \
+ if test -d $$mdir; then \
+ if test -f $$mdir/Makefile.PL -a ! -f $$mdir/Makefile; then \
+- cd $$mdir; $(PERL) Makefile.PL PREFIX=$(prefix); cd ..; \
++ cd $$mdir; $(PERL) Makefile.PL PREFIX=$(prefix) INSTALLDIRS=vendor; cd ..; \
+ fi; \
+ $(MAKE) -C $$mdir PREFIX=$(prefix); \
+ fi; \
+@@ -46,7 +46,7 @@
+ @for mdir in $(SUBDIRS); do \
+ if test -d $$mdir; then \
+ if test -f $$mdir/Makefile.PL -a ! -f $$mdir/Makefile; then \
+- cd $$mdir; $(PERL) Makefile.PL PREFIX=$(prefix); cd ..; \
++ cd $$mdir; $(PERL) Makefile.PL PREFIX=$(prefix) INSTALLDIRS=vendor; cd ..; \
+ fi; \
+ $(MAKE) -C $$mdir PREFIX=$(prefix) install; \
+ fi; \
diff --git a/dev-libs/clearsilver/metadata.xml b/dev-libs/clearsilver/metadata.xml
new file mode 100644
index 000000000000..6632069b5aff
--- /dev/null
+++ b/dev-libs/clearsilver/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+</pkgmetadata>