summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Vesely <jano.vesely@gmail.com>2019-04-25 18:25:05 -0400
committerMatt Turner <mattst88@gentoo.org>2019-04-26 11:08:40 -0700
commit15f78cdd9dc6aabf20f1096e568cfbd3118ce561 (patch)
tree9ee4c63a84977aa16e1126908ca0939e97364b9e /dev-libs/clhpp/clhpp-2.0.10.ebuild
parentx11-libs/libXxf86dga: Remove unnecessary XORG_DOC=doc (diff)
downloadgentoo-15f78cdd9dc6aabf20f1096e568cfbd3118ce561.tar.gz
gentoo-15f78cdd9dc6aabf20f1096e568cfbd3118ce561.tar.bz2
gentoo-15f78cdd9dc6aabf20f1096e568cfbd3118ce561.zip
dev-libs/clhpp: New package for Khronos OpenCL C++ bindings.
Headers only. Add Khronos-CLHPP license. Signed-off-by: Jan Vesely <jano.vesely@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11827 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/clhpp/clhpp-2.0.10.ebuild')
-rw-r--r--dev-libs/clhpp/clhpp-2.0.10.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/clhpp/clhpp-2.0.10.ebuild b/dev-libs/clhpp/clhpp-2.0.10.ebuild
new file mode 100644
index 000000000000..dcea074146dd
--- /dev/null
+++ b/dev-libs/clhpp/clhpp-2.0.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+DESCRIPTION="Khronos OpenCL C++ bindings"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP/"
+SRC_URI="https://github.com/KhronosGroup/OpenCL-CLHPP/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Khronos-CLHPP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+inherit python-any-r1 cmake-utils
+
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_unpack() {
+ unpack ${A}
+ # create symlink to change name
+ ln -s OpenCL-CLHPP-${PV} ${P}
+}
+
+src_prepare() {
+ # User patches + QA
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/include"
+ -DBUILD_DOCS=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_TESTS=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}