summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-23 01:25:25 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-23 01:31:25 +0100
commit264285c9a5552d11f8e5ddb91a4d2c820d9faf81 (patch)
tree7c70a5eba6dddab0dcd020b7bcbddd7d5501ee95 /dev-libs/clhpp
parentmedia-fonts/noto-emoji: Rename patches (diff)
downloadgentoo-264285c9a5552d11f8e5ddb91a4d2c820d9faf81.tar.gz
gentoo-264285c9a5552d11f8e5ddb91a4d2c820d9faf81.tar.bz2
gentoo-264285c9a5552d11f8e5ddb91a4d2c820d9faf81.zip
dev-libs/clhpp: fix installation directory
Upstream now handles the global prefix correctly so there is no need to set it to $EPREFIX/usr/include; simply $EPREFIX/usr - i.e. the Gentoo default will do. Closes: https://bugs.gentoo.org/716392 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/clhpp')
-rw-r--r--dev-libs/clhpp/clhpp-2.0.11-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/clhpp/clhpp-2.0.11-r1.ebuild b/dev-libs/clhpp/clhpp-2.0.11-r1.ebuild
new file mode 100644
index 000000000000..2325c35bccc7
--- /dev/null
+++ b/dev-libs/clhpp/clhpp-2.0.11-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Khronos OpenCL C++ bindings"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP/"
+SRC_URI="https://github.com/KhronosGroup/OpenCL-CLHPP/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Khronos-CLHPP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/OpenCL-CLHPP-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_TESTS=OFF
+ )
+ cmake_src_configure
+}