summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/console_bridge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/console_bridge')
-rw-r--r--dev-libs/console_bridge/Manifest1
-rw-r--r--dev-libs/console_bridge/console_bridge-0.2.7.ebuild35
-rw-r--r--dev-libs/console_bridge/console_bridge-9999.ebuild35
-rw-r--r--dev-libs/console_bridge/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/console_bridge/Manifest b/dev-libs/console_bridge/Manifest
new file mode 100644
index 000000000000..7593f4806cdb
--- /dev/null
+++ b/dev-libs/console_bridge/Manifest
@@ -0,0 +1 @@
+DIST console_bridge-0.2.7.tar.gz 5493 SHA256 9145f0f97337fc87b4c062a4bab6874e383dad3a303486b635d31af69ee0d536 SHA512 86e8ccfc9c48f6a73630b9871f2b7a4c2a6cd975e5890a61e622cbc9bdc01af942a5ad4c8666c85ada584d3e3b57c9064b55c4942977b275248a91d3492ed492 WHIRLPOOL 4ba146ac9a8f57bf37e994b74e50d66c7a82cad9aa080b8eb2f067c3837b2f65c0b5aab1490892a2b89897af70a53d46d93c62decbd8cdc1952517a1e6b8d286
diff --git a/dev-libs/console_bridge/console_bridge-0.2.7.ebuild b/dev-libs/console_bridge/console_bridge-0.2.7.ebuild
new file mode 100644
index 000000000000..3bc6b4a7d8dd
--- /dev/null
+++ b/dev-libs/console_bridge/console_bridge-0.2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros/console_bridge"
+fi
+
+inherit ${SCM} cmake-utils multilib
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout for ROS-dependent packages."
+HOMEPAGE="http://wiki.ros.org/console_bridge"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/DESTINATION lib/DESTINATION $(get_libdir)/" CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
diff --git a/dev-libs/console_bridge/console_bridge-9999.ebuild b/dev-libs/console_bridge/console_bridge-9999.ebuild
new file mode 100644
index 000000000000..3bc6b4a7d8dd
--- /dev/null
+++ b/dev-libs/console_bridge/console_bridge-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros/console_bridge"
+fi
+
+inherit ${SCM} cmake-utils multilib
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout for ROS-dependent packages."
+HOMEPAGE="http://wiki.ros.org/console_bridge"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/DESTINATION lib/DESTINATION $(get_libdir)/" CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
diff --git a/dev-libs/console_bridge/metadata.xml b/dev-libs/console_bridge/metadata.xml
new file mode 100644
index 000000000000..2cafc17dec1e
--- /dev/null
+++ b/dev-libs/console_bridge/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/console_bridge</remote-id>
+ </upstream>
+</pkgmetadata>