summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 13:50:07 +0000
committerSam James <sam@gentoo.org>2021-02-08 14:53:58 +0000
commitd1542c922ef3e2f1588a1bf3ab6cb8716dbacef0 (patch)
treec727fc3aeeceb89f7abf0169a5d6eb7556bdd072 /dev-libs/crypto++
parentnet-misc/connman: bump to 1.39, drop unneeded snapshot (diff)
downloadgentoo-d1542c922ef3e2f1588a1bf3ab6cb8716dbacef0.tar.gz
gentoo-d1542c922ef3e2f1588a1bf3ab6cb8716dbacef0.tar.bz2
gentoo-d1542c922ef3e2f1588a1bf3ab6cb8716dbacef0.zip
dev-libs/crypto++: fix musl build
Closes: https://bugs.gentoo.org/762997 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/crypto++-8.2.0-r2.ebuild3
-rw-r--r--dev-libs/crypto++/crypto++-8.4.0.ebuild4
-rw-r--r--dev-libs/crypto++/files/crypto++-8.2.0-musl-ldconfig.patch24
3 files changed, 30 insertions, 1 deletions
diff --git a/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild b/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
index 1ffe175e83b9..a52ee90857ea 100644
--- a/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
+++ b/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,7 @@ S="${WORKDIR}"
PATCHES=(
"${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${PN}-8.2.0-musl-ldconfig.patch"
)
config_add() {
diff --git a/dev-libs/crypto++/crypto++-8.4.0.ebuild b/dev-libs/crypto++/crypto++-8.4.0.ebuild
index c28c2e43f1c1..ed056d9020c1 100644
--- a/dev-libs/crypto++/crypto++-8.4.0.ebuild
+++ b/dev-libs/crypto++/crypto++-8.4.0.ebuild
@@ -17,6 +17,10 @@ IUSE="+asm static-libs"
BDEPEND="app-arch/unzip"
+PATCHES=(
+ "${FILESDIR}/${PN}-8.2.0-musl-ldconfig.patch"
+)
+
config_uncomment() {
sed -i -e "s://\s*\(#define\s*$1\):\1:" config.h || die
}
diff --git a/dev-libs/crypto++/files/crypto++-8.2.0-musl-ldconfig.patch b/dev-libs/crypto++/files/crypto++-8.2.0-musl-ldconfig.patch
new file mode 100644
index 000000000000..2ae8d287e12e
--- /dev/null
+++ b/dev-libs/crypto++/files/crypto++-8.2.0-musl-ldconfig.patch
@@ -0,0 +1,24 @@
+https://github.com/void-ppc/void-packages/blob/master/srcpkgs/crypto++/patches/musl-soname-links.patch
+https://bugs.gentoo.org/762997
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -1256,7 +1256,7 @@
+ $(CHMOD) 0755 $(DESTDIR)$(LIBDIR)/libcryptopp.so$(SOLIB_VERSION_SUFFIX)
+ ifeq ($(HAS_SOLIB_VERSION),1)
+ -$(LN) libcryptopp.so$(SOLIB_VERSION_SUFFIX) $(DESTDIR)$(LIBDIR)/libcryptopp.so
+- $(LDCONF) $(DESTDIR)$(LIBDIR)
++ -$(LN) libcryptopp.so$(SOLIB_VERSION_SUFFIX) $(DESTDIR)$(LIBDIR)/libcryptopp.so$(SOLIB_COMPAT_SUFFIX)
+ endif
+ endif
+ ifneq ($(wildcard libcryptopp.pc),)
+--- a/GNUmakefile-cross
++++ b/GNUmakefile-cross
+@@ -732,7 +732,7 @@
+ $(CHMOD) 0755 $(DESTDIR)$(LIBDIR)/libcryptopp.so$(SOLIB_VERSION_SUFFIX)
+ ifeq ($(HAS_SOLIB_VERSION),1)
+ -$(LN) libcryptopp.so$(SOLIB_VERSION_SUFFIX) $(DESTDIR)$(LIBDIR)/libcryptopp.so
+- $(LDCONF) $(DESTDIR)$(LIBDIR)
++ -$(LN) -sf libcryptopp.so$(SOLIB_VERSION_SUFFIX) $(DESTDIR)$(LIBDIR)/libcryptopp.so$(SOLIB_COMPAT_SUFFIX)
+ endif
+ endif
+ ifneq ($(wildcard libcryptopp.pc),)