summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-10-06 00:45:51 +0100
committerRobin H. Johnson <robbat2@gentoo.org>2017-01-22 12:58:48 -0800
commit2749083e16c416005352bc0634ca2690a0b44f34 (patch)
treece81c0d3be89db2428668377b65ca36017f02b3f /dev-libs/device-atlas-api-c
parentdev-libs/botan: version bump (diff)
downloadgentoo-2749083e16c416005352bc0634ca2690a0b44f34.tar.gz
gentoo-2749083e16c416005352bc0634ca2690a0b44f34.tar.bz2
gentoo-2749083e16c416005352bc0634ca2690a0b44f34.zip
dev-libs/device-atlas-api-c: API to detect devices based on the User-Agent HTTP header
Package-Manager: portage-2.3.0 (cherry picked from commit b9475e94910837345e1ff1e426c0d573a23131aa) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-libs/device-atlas-api-c')
-rw-r--r--dev-libs/device-atlas-api-c/Manifest1
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild51
-rw-r--r--dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch20
-rw-r--r--dev-libs/device-atlas-api-c/metadata.xml15
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/Manifest b/dev-libs/device-atlas-api-c/Manifest
new file mode 100644
index 000000000000..8199f8ea1141
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/Manifest
@@ -0,0 +1 @@
+DIST deviceatlas-enterprise-c-2.1.zip 504286 SHA256 a02fc29486d245b1c8d946c663b71ba981e88fee8d037f5bc1bf255deb287974 SHA512 99a8e89f3d1c084a93b184685108ea65d1fd925e0c8b52599a42dbe70af3126103da0a9fd284b14ddf59b996204334d360a12651025413bc4d7f76054779275b WHIRLPOOL 939733a58f352cbeee852ccfea3f2f022310ceb7363a15889d9a6366532102ee700271b6008e0a57ae4d86cafe6354409f9520105e46eaabb5c41f1a7827f1b4
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild
new file mode 100644
index 000000000000..f866a8d0af35
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit unpacker cmake-multilib
+
+MY_P="deviceatlas-enterprise-c-${PV}"
+
+DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
+HOMEPAGE="https://deviceatlas.com"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-cmake-install.patch"
+)
+
+pkg_nofetch() {
+ eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
+ eerror "And download DeviceAtlas C API"
+ eerror "Then place the file in ${DISTDIR}/${MY_P}.zip"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ local -a HTML_DOCS=( Documentation )
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/daexutil.h
+ doins examples/example{0,1,2,3}.c
+ doins examples/util.c
+ doins examples/EXAMPLES.USAGE
+ fi
+
+ einstalldocs
+}
diff --git a/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch b/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch
new file mode 100644
index 000000000000..9f518629e5a1
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch
@@ -0,0 +1,20 @@
+--- ./CMakeLists.txt 2016-11-08 22:54:33.351677837 +0000
++++ ./CMakeLists.txt 2016-11-08 23:04:26.737184360 +0000
+@@ -16,6 +16,7 @@
+ set(MODEL 64)
+ endif()
+
++include(GNUInstallDirs)
+ message(STATUS "${CMAKE_BUILD_TYPE} version")
+
+ include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+@@ -31,6 +32,9 @@
+
+ add_subdirectory(examples)
+
++install(TARGETS da DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES dac.h dac_json.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
++
+ if (EXISTS "${PROJECT_SOURCE_DIR}/tests")
+ subdirs(tests)
+ endif()
diff --git a/dev-libs/device-atlas-api-c/metadata.xml b/dev-libs/device-atlas-api-c/metadata.xml
new file mode 100644
index 000000000000..a1a8f31a03a3
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ DeviceAtlas is the de facto standard for device data across the web, telco, advertising and digital marketing sectors. As the only solution that is indexed for both web and mobile operator environments, DeviceAtlas' patented technology provides a common device identifier to understand device traffic across all connected environments.
+ </longdescription>
+</pkgmetadata>