summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2017-08-31 20:01:53 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-07 17:56:37 +0200
commitd04b19f312e924f9203e2993d771230d8ae3c8ba (patch)
treeeb0cede8cafe1b77566f1c02a528305f523dcdcd /dev-libs/device-atlas-api-c
parentdev-lisp/asdf: Bumps version to 3.3.0 (diff)
downloadgentoo-d04b19f312e924f9203e2993d771230d8ae3c8ba.tar.gz
gentoo-d04b19f312e924f9203e2993d771230d8ae3c8ba.tar.bz2
gentoo-d04b19f312e924f9203e2993d771230d8ae3c8ba.zip
dev-libs/device-atlas-api-c: version bump to 2.1.2_2.
Closes: https://github.com/gentoo/gentoo/pull/5572
Diffstat (limited to 'dev-libs/device-atlas-api-c')
-rw-r--r--dev-libs/device-atlas-api-c/Manifest1
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/Manifest b/dev-libs/device-atlas-api-c/Manifest
index de4fbaa478c0..c1f9518f5e69 100644
--- a/dev-libs/device-atlas-api-c/Manifest
+++ b/dev-libs/device-atlas-api-c/Manifest
@@ -1,2 +1,3 @@
DIST deviceatlas-enterprise-c-2.1.2_1.tgz 184432 SHA256 984e1ae3147459a4ed0a8d5053d83dd05ce8c5127cd3cb055be35a74e9217372 SHA512 4ff269c55e74688dc1c954a1d9b0fc28aa135eccd20089f4da390522644bd1c08e2bc38e4ad15a64308a0e91b007a820dcdc3998c262fa5a7cfe1038e9f0e969 WHIRLPOOL 73c1c7eec0daed7632e8a5a7ceda956ec91cc603fe45df2fdbf2b54ecc950bd72ff59fdd85ff6a0ee70d54b2099ecc3219ef55f4aecb308f254851f93fe57738
+DIST deviceatlas-enterprise-c-2.1.2_2.tgz 184368 SHA256 feaa9198a5d6bed125b34742bd626ad0a0fcb862803916cd7d974413f8bdfdce SHA512 46c021b3430c6900f9172c13cdeb26931634345485c2fe0fe7b6911f7c6f6bee46ab3551e4fe11ef5b5caabe66c786c72b51db6875aa9d44aab673056b9debee WHIRLPOOL d85161010cf195eab5ef9c4e83404ad08cc10d607ace5bc6424ffb170ca09a26d5410534279eab1d721615db943f3a447ff908f62f76311ec80c3d95abbb49d4
DIST deviceatlas-enterprise-c-2.1.zip 504286 SHA256 a02fc29486d245b1c8d946c663b71ba981e88fee8d037f5bc1bf255deb287974 SHA512 99a8e89f3d1c084a93b184685108ea65d1fd925e0c8b52599a42dbe70af3126103da0a9fd284b14ddf59b996204334d360a12651025413bc4d7f76054779275b WHIRLPOOL 939733a58f352cbeee852ccfea3f2f022310ceb7363a15889d9a6366532102ee700271b6008e0a57ae4d86cafe6354409f9520105e46eaabb5c41f1a7827f1b4
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p2.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p2.ebuild
new file mode 100644
index 000000000000..2923dead8a25
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+MY_P="deviceatlas-enterprise-c-${PV/_p/_}"
+
+DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
+HOMEPAGE="https://deviceatlas.com"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-src-cmakelists.patch"
+)
+
+pkg_nofetch() {
+ eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
+ eerror "And download DeviceAtlas C API"
+ eerror "Then place the file in ${DISTDIR}/${MY_P}.tgz"
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local -a HTML_DOCS=( Documentation )
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/daexutil.h
+ doins examples/example{0,1,2,3}.c
+ doins examples/util.c
+ doins examples/EXAMPLES.USAGE
+ fi
+
+ einstalldocs
+}