summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-18 20:11:07 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-18 20:11:07 +0100
commitb5aabfdb9394719896261a3f888d3131552ce93a (patch)
treeea2013867fa685389de65b9467db5525ef76ef32 /dev-libs/dmalloc
parentdev-libs/fcgi: Port to EAPI 7 (diff)
downloadgentoo-b5aabfdb9394719896261a3f888d3131552ce93a.tar.gz
gentoo-b5aabfdb9394719896261a3f888d3131552ce93a.tar.bz2
gentoo-b5aabfdb9394719896261a3f888d3131552ce93a.zip
dev-libs/dmalloc: Remove old
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/dmalloc')
-rw-r--r--dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild76
-rw-r--r--dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild85
2 files changed, 0 insertions, 161 deletions
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild
deleted file mode 100644
index 0e973b234971..000000000000
--- a/dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools eutils multilib
-
-DESCRIPTION="A Debug Malloc Library"
-HOMEPAGE="http://dmalloc.com"
-SRC_URI="http://dmalloc.com/releases/${P}.tgz"
-
-LICENSE="CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
-IUSE="static-libs threads"
-
-DEPEND="sys-apps/texinfo"
-RDEPEND=""
-
-DOCS=( NEWS README docs/NOTES docs/TODO )
-
-src_prepare() {
- # - Build objects twice, once -fPIC for shared.
- # - Use DESTDIR.
- # - Fix SONAME and NEEDED.
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
- # - Broken test, always returns false.
- epatch "${FILESDIR}"/${P}-cxx.patch
- # - Add threads support.
- use threads && epatch "${FILESDIR}"/${P}-threads.patch
- # Respect CFLAGS/LDFLAGS. #337429
- sed -i Makefile.in \
- -e '/libdmalloc/ s:$(CC):& $(CFLAGS) $(LDFLAGS):g' \
- || die "sed Makefile.in"
- # - Run autoconf for -cxx.patch.
- eautoconf
-}
-
-src_configure() {
- econf --enable-cxx --enable-shlib $(use_enable threads)
-}
-
-src_compile() {
- default
-
- cd docs
- makeinfo dmalloc.texi || die
-}
-
-src_test() {
- emake heavy
-}
-
-src_install() {
- default
-
- newdoc ChangeLog.1 ChangeLog
- insinto /usr/share/doc/${PF}
- doins docs/dmalloc.pdf
- dohtml RELEASE.html docs/dmalloc.html
- doinfo docs/dmalloc.info
-
- # add missing symlinks, lazy
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV%%.*}
-
- for lib in cxx th thcxx; do
- dosym lib${PN}${lib}.so.${PV} /usr/$(get_libdir)/lib${PN}${lib}.so
- dosym lib${PN}${lib}.so.${PV} \
- /usr/$(get_libdir)/lib${PN}${lib}.so.${PV%%.*}
- done
-
- if ! use static-libs; then
- rm "${D}"/usr/$(get_libdir)/lib${PN}*.a || die
- fi
-}
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild
deleted file mode 100644
index 89f15be52534..000000000000
--- a/dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="A Debug Malloc Library"
-HOMEPAGE="http://dmalloc.com"
-SRC_URI="http://dmalloc.com/releases/${P}.tgz"
-
-LICENSE="CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="static-libs threads"
-
-DEPEND="sys-apps/texinfo"
-RDEPEND=""
-
-DOCS=( NEWS README docs/NOTES docs/TODO )
-
-src_prepare() {
- # - Build objects twice, once -fPIC for shared.
- # - Use DESTDIR.
- # - Fix SONAME and NEEDED.
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
-
- # - Broken test, always returns false.
- epatch "${FILESDIR}"/${P}-cxx.patch
- epatch "${FILESDIR}"/${P}-ar.patch
-
- # - Add threads support.
- use threads && epatch "${FILESDIR}"/${P}-threads.patch
-
- # strdup() strndup() macros
- epatch "${FILESDIR}"/${P}-string-macros.patch
-
- # Respect CFLAGS/LDFLAGS. #337429
- sed -i \
- -e '/libdmalloc/ s:$(CC):& $(CFLAGS) $(LDFLAGS):g' \
- -e 's|ar cr|$(AR) cr|g' \
- Makefile.in || die
-
- # Run autoconf for -cxx.patch.
- eautoconf
-}
-
-src_configure() {
- tc-export AR
- econf --enable-cxx --enable-shlib $(use_enable threads)
-}
-
-src_compile() {
- default
-
- cd docs
- makeinfo dmalloc.texi || die
-}
-
-src_test() {
- emake heavy
-}
-
-src_install() {
- default
-
- newdoc ChangeLog.1 ChangeLog
- insinto /usr/share/doc/${PF}
- doins docs/dmalloc.pdf
- dohtml RELEASE.html docs/dmalloc.html
- doinfo docs/dmalloc.info
-
- # add missing symlinks, lazy
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV%%.*}
-
- for lib in cxx th thcxx; do
- dosym lib${PN}${lib}.so.${PV} /usr/$(get_libdir)/lib${PN}${lib}.so
- dosym lib${PN}${lib}.so.${PV} \
- /usr/$(get_libdir)/lib${PN}${lib}.so.${PV%%.*}
- done
-
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/lib${PN}*.a || die
- fi
-}